Team's contact e-mail address options should be more obvious

Bug #31590 reported by Matthew Paul Thomas
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Low
Ian Booth

Bug Description

Currently <https://launchpad.net/people/+newteam> includes a "Contact Email Address" field: "This is the email address we'll send all notifications to this team. If no contact address is chosen, notifications directed to this team will be sent to all team members. After finishing the team creation, a new message will be sent to this address with instructions on how to finish its registration."

The confirmation process seems unnecessary. I don't need to use e-mail to finish the registration of a product or a project, so why do I need to for a team? It has also caused confusion about whether this address is for team administration, or team-wide notifications.

The confirmation process should be removed, and this part of the form should be rendered like this:

Messages for the team should be sent to:
(*) Each member individually
( ) A mailing list address: [______]

The same applies to the page for changing the address after the fact (+editemail).

Related branches

description: updated
Changed in launchpad:
status: Unconfirmed → Confirmed
Revision history for this message
Barry Warsaw (barry) wrote :

The other problem with this work flow is that a confirmation message really should not be sent to a mailing list's posting address. It's highly likely that such a confirmation message would get held for approval if the mailing list limits non-member posts. That would accidentally be okay because it's probable that the list owner is creating that connection between the team and the external mailing list, and they'll be able to see the held message and complete the confirmation process.

It's even worse though if the message gets posted to the list, because then any list member would be able to complete the confirmation.

There should be a way for a list owner to complete the confirmation (or avoid it) for setting a team's contact address to an external mailing list.

Revision history for this message
Curtis Hovey (sinzui) wrote :

This issue can be addressed as a part of an effort to revised the team registration process.

Changed in launchpad-registry:
importance: Medium → Low
status: Confirmed → Triaged
Curtis Hovey (sinzui)
tags: added: teams
tags: added: email
Ian Booth (wallyworld)
Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Ian Booth (wallyworld)
Revision history for this message
Ian Booth (wallyworld) wrote :

This bug is related to 1020296.

The contact address field is being removed from the new team form, so by default notifications for new teams will go directly to each member.

If a mailing list is used, it must be a Launchpad mailing list. The list is named after the team, and creation of the list is managed by Launchpad. So it is not feasible to allow an exiting mailing list to be entered directly. Once a mailing list has been created for the team using the Create Mailing List option, it will be offered as a choice for contact address.

Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Ian Booth (wallyworld)
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant)
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers