build.distro_arch_series confusingly named

Bug #30084 reported by Daniel Silverstone on 2006-01-30
Affects Status Importance Assigned to Milestone
Launchpad itself

Bug Description

The column 'distrorelease' in the build table is confusingly named.

Ideally we should call it something which reflects the fact that it is the distroarchrelease that the packages were built on, but not necessarily that which they were published in.

E.g. call is distroarchrelease_builtfor or builtfor_distroarchrelease or something.

Dafydd Harries (daf) wrote :

Even distroarchrelease would be better than distrorelease. I'd go for distroarchrelease_built_for.

Changed in launchpad:
status: Unconfirmed → Confirmed
Daniel Silverstone (dsilvers) wrote :

no movement?

Celso Providelo (cprov) wrote :

Well, I don't think that the IBuild.distroarchrelease & distrorelease are that confusing.
We could update the attribute descriptions to provide a more accurate documentation, but don't think that the renaming is necessary.

Changed in launchpad:
importance: Medium → Wishlist
Colin Watson (cjwatson) on 2012-08-11
summary: - build.distrorelease confusingly named
+ build.distro_arch_series confusingly named
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers