invalid moldavian language used in launchpad

Bug #296751 reported by Lucian Adrian Grijincu
12
Affects Status Importance Assigned to Milestone
Launchpad itself
Won't Fix
Undecided
Jeroen T. Vermeulen

Bug Description

There is a „Moldavian” language in https://edge.launchpad.net/people/+me/+editlanguages.
This language was declared deprecated by ISO/DIS 639-3[9] and is considered equal to the Romanian language (the name of the language was invented by the Moldavian authorities, there are no differences between the language spoken in Moldavia and the one spoken in Romania).

<quote src="http://en.wikipedia.org/wiki/Moldovan_language">
Moldovan was assigned the code mo in ISO 639-1 and code mol in ISO 639-2 and ISO/DIS 639-3[9] but these have been deprecated as of November 2008, leaving ro and ron (639-2/T) and rum (639-2/B) the current language identifiers to be used for the variant of the Romanian language also known as Moldavian and Moldovan in English, the ISO 639-2 Registration Authority said in the motivation of the decision.[10]
</quote>

This language should be removed from Launchpad itself together with all so called „moldavian” translations.
Furthermore, the language seems to be unsupported in launchpad: going to https://translations.edge.launchpad.net/ubuntu/intrepid/+source/gnome-orca/+pots/orca/mo/+translate echoes this error:
„ Launchpad can’t handle the plural items in this file, because it doesn’t yet know how plural forms work for Moldavian. ”

Revision history for this message
Diogo Matsubara (matsubara) wrote :

Danilo, can you do this?

Changed in launchpad:
assignee: nobody → danilo
Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

I've just removed Moldovian from the list of visible languages in Launchpad.

Launchpad still knows about the language, so anyone who has Moldovian in their list of preferred languages can still select it as a source of suggestions on the translation pages. This should allow translation reviewers to complement existing Romanian translations with Moldavian ones without too much trouble.

Copying translations would take considerable time to arrange, and there is always a risk of mistakes—especially by us engineers who don't speak Romanian. Doing it this way is safer, and only costs any extra effort where messages have been translated into Moldavian but not into Romanian.

Changed in rosetta:
assignee: danilo → jtv
milestone: none → 2.1.12
status: New → Fix Released
Revision history for this message
Lucian Adrian Grijincu (lucian.grijincu) wrote :

I can still see Moldavian in this list https://translations.edge.launchpad.net/ubuntu/jaunty/+source/iso-codes/+pots/iso-639-3
If I understood correctly one should only see Moldavian in suggestion boxes, not anywhere else.
What's worse: I can also edit it (I made a submission to check whether it worked or not).

Revision history for this message
Lucian Adrian Grijincu (lucian.grijincu) wrote :

As I said in the description, I think there is no reason to keep this language any more.
The Romanian translation team has lots of new contributors, and there were not very many Moldavian translators to begin with. This language was used for a brief period of time.
The benefit of having it remain in the system for old translators that still have it visible is from my POV lower than the costs of confusion and

Could you please check how many users can still see the language?
Could you find out if they are major contributors?
Could you check whether there are packages with „Moldavian” translations that haven't been translated in Romanian?

By analyzing this data, please say if you believe there is benefit from keeping it in the system or making it disappear for all users (I don't care if you keep internal copies în Launchpad for whichever reason).

Another thing to keep in mind: Launchpad is going to be released (at least if Mark Shuttleworth keeps his promise) as open source. Think about this: should this „feature” creep in the released code? Shouldn't you kill it here so it won't manifest itself in various other projects.

Revision history for this message
Lucian Adrian Grijincu (lucian.grijincu) wrote :

I've reopened the bug as „Moldavian” is visible in various places such as https://translations.edge.launchpad.net/ubuntu/jaunty/+lang/mo

Changed in rosetta:
status: Fix Released → New
Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

We've made the language invisible in most listings (although we don't go as far as hiding actual Moldavian *translations* ) but bookmarked links straight to Moldavian pages will still work.

Removing a language entirely is technically very hard, and labour-intensive. Since it's very rare we don't have any standing facilities for it. And singling the language out as a special case is no easier. Given how short-handed we are, it's more effective for translation teams to coordinate among themselves.

Revision history for this message
Данило Шеган (danilo) wrote :

This is not a bug per se. We won't hide actual existing translations, but if the community asks us to do something with them (i.e. remove them) after they have made use of them (to eg. complete Romanian translations), we'd be happy to accommodate as time permits (which means we won't rush into it since it is a hard, involved job, which will take a lot of time to carry out). Also, since that's more of a administrative task, please file it as https://answers.launchpad.net/rosetta as a question once you've decided what you want to do, because that helps us keep track of the request and it's progress.

If you don't want Ubuntu to include Moldavian as the language, please file a separate bug against language-pack-mo, or open a bug task on this bug for it.

Changed in rosetta:
status: New → Won't Fix
Revision history for this message
Lucian Adrian Grijincu (lucian.grijincu) wrote : Re: [Bug 296751] Re: invalid moldavian language used in launchpad

On Wed, Dec 3, 2008 at 4:58 PM, Jeroen T. Vermeulen <email address hidden> wrote:
> Launchpad still knows about the language, so anyone who has Moldovian in
> their list of preferred languages can still select it as a source of
> suggestions on the translation pages.  This should allow translation
> reviewers to complement existing Romanian translations with Moldavian
> ones without too much trouble.

I just checked all 1632 packages in Karmic
   https://translations.edge.launchpad.net/ubuntu/karmic/+lang/mo

There is NO language that has translated strings.

> Copying translations would take considerable time to arrange, and there
> is always a risk of mistakes—especially by us engineers who don't speak
> Romanian.  Doing it this way is safer, and only costs any extra effort
> where messages have been translated into Moldavian but not into
> Romanian.

As I said there is nothing to copy. There are no translations done for
Moldavian.

As it is stated in the description of this bug, this language is not a
real one, it was a temporary name given for political reasons to the
Romanian language in Moldova.

Ubuntu does not even ship a language-pack-mo, pack-gnome-mo or any
other moldavian package (as I see in `apt-cache search`).

--
 .
..: Lucian

Revision history for this message
Henning Eggers (henninge) wrote :

Please remember that Ubuntu is not the only project using Launchpad and karmic is not the only series and that there is more stuff in Launchpad than what ends up in Ubuntu. There *are* Moldavian translations in Launchpad but as the language has been disabled and is not even used for Ubuntu (as you pointed out), I don't see a reason to hurry. This is more of a clean-up task that we'll do when time permits.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions