Lack of definition within launchpad on bug status meanings

Reported by Matthias Klose on 2006-01-23
56
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Ian Booth

Bug Description

is there any place where the malone status "Fix committed" and "Fix released" is described? I only can guess about the semantics of these values.
bugzilla did allow to select a link on the "Status:" word leading to a description page.

Brad Bollenbach (bradb) on 2006-03-03
Changed in malone:
status: Unconfirmed → Confirmed
Alban Crequy (muadda) wrote :

I guess the semantics of malone status "Fix committed" and "Fix released" are not defined at all. Also see Bug #28698

Alban Crequy (muadda) wrote :

The status "confirmed" and "unconfirmed" are also not explained. Should I confirm my own bug or should I wait somebody else to confirm my own bug?

On 3-Mar-06, at 1:59 PM, Alban Crequy wrote:

> Public bug report changed:
> https://launchpad.net/malone/bugs/29495
>
> Comment:
> The status "confirmed" and "unconfirmed" are also not explained.
> Should
> I confirm my own bug or should I wait somebody else to confirm my own
> bug?

If you even have to ask--and, rest assured, I can understand how
these statuses might be interpreted differently by different people--
then the answer almost doesn't even matter. :) If the UI makes it
less than completely clear, then it's nearly guaranteed that many
people won't Do The Right Thing anyway.

You probably shouldn't confirm your own bug unless you're a developer
on the thing you're reporting, or otherwise experienced enough to be
sure your bug indeed exists, is filed on the correct package, and is
explained clearly enough that a developer can jump in and fix it.

Cheers,

--
Brad Bollenbach

> unless you're a developer
> on the thing you're reporting, or otherwise experienced enough to be
> sure your bug indeed exists, is filed on the correct package, and is
> explained clearly enough that a developer can jump in and fix it

or it's not a dupe :P

Joey Stanford (joey) wrote :

Hi,

The status descriptions are linked now from the bug report it self to this page which describes them in greater detail: https://help.launchpad.net/BugStatuses

Since this bug appears to be resolved, I'm going to close it. If there is a usability problem with the way this is currently implemented, please open a new bug so it is triaged appropriately.

Thanks!

Changed in malone:
assignee: nobody → rinchen
status: Confirmed → Invalid
era (era) wrote :

Where exactly? I cannot find that link, even if I view the HTML source for https://bugs.launchpad.net/malone/+bug/29495

Joey Stanford schrieb:
> Since this bug appears to be resolved, I'm going to close it.
> Status: Confirmed => Invalid

you fixed it and marked it as invalid?

Ok Matthias, you win. :-) I'll mark this as Fixed Release since the material is both in LP for filing bugs as well as the wiki page. I'll locate an example of the bug status item in LP and post that as an additional comment.

Changed in malone:
status: Invalid → Fix Released
Joey Stanford (joey) wrote :

I greped the code and it appears the BugStatus inside Launchpad only is visible for those bugs set to expire. See bug 138999 as an example. I'll add the suggestion to link to that page permanently as part of the revised help system we've got schedule for the near future.

era (era) wrote :

Joey Stanford: That's bug #185851 (too).

See also duplicate bug #185853 which was clearly filed after the explanation was added to bugs which are set to expire. (I filed it specifically when I noticed that BugStatuses exists but is not linked where I had expected it to be.) I really don't think it's appropriate to close this bug until the actual problem is actually fixed.

Changed in malone:
assignee: rinchen → nobody
status: Fix Released → Confirmed
Joey Stanford (joey) wrote :

Hi era,

Ok, I understand what you are after now. In addition to some related help items which I've recommended to the help spec we're working on, perhaps changing the linkage of the Status field would be of benefit as described in Bug 137448. I've linked that bug back here as well. Would this address your concerns?

era (era) wrote :

Joey Stanford,

These issues are related, but what I would expect (based on other bug trackers, for example Bugzilla) would be for the header to link to an explanation, and the field itself to be editable.

In pseudo-HTML, something like this:

  <table>
    <tr>
      <th><a href="link explaining 'affects' field, maybe?">Affects</a></th>
      <th><a href="BugStatuses">Status</a></th>
      <th><a href="link explaining 'Importance' field">Importance</a></th>
      <th><a href="link explaining 'assigned to', maybe?">Assigned to</a></th>
    </tr>
    <tr>
      <td><a href="link to edit package, maybe?">Lunchbox Bugs</a></td>
      <td><a href="link to edit status">Confirmed</a></td>
      <td><a href="link to edit importance">Medium</a></td>
      <td><a href="link to edit assignee?">Joey Stanford</a></td>
    </tr>
    <!-- .... -->
  </table>

I'm not too sure about this, but IMNSHO the "expander" arrows are too small by themselves to be comfortable to click (this properly belongs to the discussion in bug 137448 I guess). On the other hand, some people might expect the links in the headers to be used for sorting on a field, although for most bug reports, that doesn't really make much sense (I guess you would need to be able to sort only when you have more than about three affected packages).

Rainer (rainer.blome) wrote :

Why hasn't this been fixed yet?
It's not that people *could* set the status wrong, they *do* set the status wrong.
Most commonly, they use "Incomplete" when a change has been published which does not completely resolve the issue.

Either link both instances of "Status" to https://help.launchpad.net/Bugs/Statuses (or http://news.launchpad.net/general/of-bugs-and-statuses or whereever), as era suggested,
or change the display names of the status.

For example:
"Incomplete" -> "Bug description is incomplete" or "Need more information"
"Invalid" -> "Rejected"
"Confirmed" -> "Independently confirmed"
"Triaged" -> "Assigned"
"In progress" -> "Work in progress" or even "Fixing is in progress"
"Fix Committed" -> "Fix has been checked in"
"Fix Released" -> "Fix has been released"

Samuel Bronson (naesten) wrote :

I'm attaching a screenshot on which I have circled exactly where a help link for this should go.

Samuel Bronson (naesten) wrote :

I do agree with era that the headers should link to the fields' documentation if they aren't going to do anything else useful.

(I am also sorely tempted to set this bug's status to something inappropriate and wish I could say I the same about Importance.)

Tom Berger (intellectronica) wrote :

@naesten, soon we'll be moving to inline editing of statuses, so that form will be gone. fortunately, our inline editing widget has some place for explanatory text.

Changed in launchpad:
importance: Medium → High
summary: - Bug statuses should be better explained
+ No explanation or help for bug status field values on bug index pages
Curtis Hovey (sinzui) on 2011-10-22
tags: added: docs
Changed in launchpad:
importance: High → Low
Curtis Hovey (sinzui) on 2011-11-13
summary: - No explanation or help for bug status field values on bug index pages
+ Lack of definition within launchpad on bug status meanings
Curtis Hovey (sinzui) on 2012-05-30
Changed in launchpad:
assignee: nobody → Ian Booth (wallyworld)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Related blueprints