security private PPA debdiff generator uses the wrong pocket

Bug #294886 reported by Kees Cook on 2008-11-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Unassigned

Bug Description

Perhaps related to bug 237092, it seems that the security P3A generates debdiffs against the release pocket, not the security pocket. (e.g. 2.6.24-16.23 (in Ubuntu) to 2.6.24-21.33 when it should be from 2.6.24-21.32).

Celso Providelo (cprov) wrote :

Yes, that's true. Diff ancestries should be looked up across pockets (differently than the upload ancestry). I wonder if it would be less of problem if a new arbitrary diff could be requested manually.

Changed in soyuz:
importance: Undecided → High
milestone: none → pending
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers