Hide translations for obsolete distroseries

Bug #280647 reported by Jeroen T. Vermeulen
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Medium
Jeroen T. Vermeulen

Bug Description

Translations for obsolete distroseries can continue to take up server resources: spiders still crawl their pages, people can still translate, we still generate suggestions for them, and files can still be uploaded.

We can use the hide_translations flag to "turn off" these obsolete translations. The only problem is that the templates currently say that translations are hidden because we are copying translations in bulk. There can be other reasons to hide translations as well, e.g. data migrations, so we could update the language there to be more generic.

Changed in rosetta:
importance: Undecided → Medium
milestone: none → 2.1.11
status: New → Triaged
Changed in rosetta:
assignee: nobody → jtv
status: Triaged → In Progress
Changed in rosetta:
milestone: 2.1.11 → 2.1.12
Changed in rosetta:
milestone: 2.1.12 → 2.2.1
Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

We should also clear out the import queues for the old release series.

Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

Separate blueprint for automating the clearing of queues for obsolete series:

https://blueprints.launchpad.net/rosetta/+spec/clear-obsolete-import-queue

Changed in rosetta:
status: In Progress → Fix Committed
Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

Looks like this branch didn't go in after all. Re-submitting.

Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

Nope, nope, it's not that. Then edge and staging must not have updated.

Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

Unfortunately this fix did cause a regression; see bug 314616.

Changed in rosetta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers