Hookable error logging for smart servers

Reported by Michael Hudson-Doyle on 2008-09-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
Jonathan Riddell
Launchpad itself
High
Unassigned

Bug Description

If something unexpected happens in the 'bzr lp-serve' process we spawn on a bzr+ssh connection, we don't find out about it (well, we probably get a report that a subprocess exited with code 1 in our logs). The unlucky user probably gets a traceback in their terminal.

We should log an oops.

I think we can probably do this in sys.excepthook.

Related branches

Jonathan Lange (jml) wrote :

This is really important to fix. We need error reporting.

Changed in launchpad-bazaar:
importance: Undecided → High
status: New → Triaged
Jonathan Lange (jml) on 2009-06-23
tags: added: codehosting-ssh
Jonathan Lange (jml) on 2009-06-23
Changed in launchpad-code:
assignee: nobody → Jonathan Lange (jml)
status: Triaged → In Progress
Jonathan Lange (jml) on 2009-07-15
Changed in launchpad-code:
status: In Progress → Fix Committed
Jonathan Lange (jml) wrote :

I ended up doing this by monkeypatching bzrlib.trace.log_exception_quietly. That doesn't work, however, since modules import log_exception_quietly before the monkeypatcher runs. Suck.

I'm going to do this right by adding a hook to bzr itself.

Changed in launchpad-code:
status: Fix Committed → In Progress
milestone: none → 2.2.9
Jonathan Lange (jml) wrote :

I'll add the hook to bzr.

Changed in bzr:
assignee: nobody → Jonathan Lange (jml)
importance: Undecided → Medium
status: New → In Progress
summary: - tracebacks in lp-serve are not logged anywhere
+ Hookable error logging for smart servers
Matthew Revell (matthew.revell) wrote :

Retargeting to 3.0, which is the new name for 2.2.9. Haven't renamed the milestone as the 3.0 milestone is in a different series.

Changed in launchpad-code:
milestone: 2.2.9 → 3.0
Jonathan Lange (jml) on 2009-09-03
Changed in bzr:
status: In Progress → Triaged
Changed in launchpad-code:
status: In Progress → Triaged
Jonathan Lange (jml) wrote :

As mentioned in my earlier comment, this requires a change to Bazaar. However, I'm not going to be able to do it.

Changed in bzr:
assignee: Jonathan Lange (jml) → nobody
Changed in launchpad-code:
assignee: Jonathan Lange (jml) → nobody
Tim Penhey (thumper) on 2009-09-18
Changed in launchpad-code:
milestone: 3.0 → 3.1.10
Tim Penhey (thumper) on 2009-11-01
Changed in launchpad-code:
milestone: 3.1.10 → none
Martin Pool (mbp) on 2010-03-18
Changed in bzr:
status: Triaged → Confirmed
Martin Pool (mbp) on 2011-02-16
Changed in bzr:
importance: Medium → High
Martin Pool (mbp) on 2011-02-17
Changed in bzr:
assignee: nobody → canonical-bazaar (canonical-bazaar)
Jonathan Riddell (jr) on 2011-05-24
Changed in bzr:
assignee: canonical-bazaar (canonical-bazaar) → Jonathan Riddell (jr)
Jonathan Riddell (jr) on 2011-05-27
Changed in bzr:
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2011-05-27
Changed in bzr:
milestone: none → 2.4b4
status: In Progress → Fix Released
tags: added: oops-infrastructure
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers