Translation gets "stuck" in wrong format

Bug #264101 reported by Jeroen T. Vermeulen on 2008-09-02
6
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

Denis Arnaud reports a problem with the Breton (br) translation for the Hardy firefox-3.0 package. He first uploaded a PO file (after fixing the many errors you typically get for an attempt to do that) and then later an XPI file. He uploaded the latter into the Breton translation, not into the template.

The XPI upload failed: the importer mistakenly believed that it was a PO file! The reason for this seems to be that the POFileUploadView prefers the existing POFile's path over the uploaded one. It does not pass a format to TranslationImportQueue.addOrUpdateEntry(), so addOrUpdateEntry() guesses the new file's format based on filename. In this case, that's the old PO filename instead of the new XPI filename.

A simple way to work around this is to make the POFileUploadView prefer the new upload's name if it has an extension that differs from what the existing POFile in the database has. A more sophisticated one would be to reuse the name in the database, but replace either the extension or the entire filename (leaving the rest of the path intact).

Denis' uploaded file is here: http://meskach.free.fr/arbo/Ubuntu-br/br.xpi

He tried to upload here: https://translations.launchpad.net/ubuntu/hardy/+source/firefox-3.0/+pots/firefox/br/+upload

Changed in rosetta:
milestone: none → 2.1.9
Changed in rosetta:
milestone: 2.1.9 → 2.1.10
Changed in rosetta:
importance: Undecided → Medium
status: New → Triaged
Changed in rosetta:
milestone: 2.1.10 → 2.1.11
Changed in rosetta:
milestone: 2.1.11 → none
Reşat SABIQ (tilde-birlik) wrote :

I have the same firefox/xulrunner problem (for jaunty) and need cleanup for crh locale followed by .xpi upload.

Please upload one of the following .xpi files:
1. attached .xpi: the same as the .xpi linked in item 2. below, but uses crh locale rather than crh-UA.
2. wget --no-check-certificate https://addons.mozilla.org/en-US/firefox/downloads/latest/7420

I have tried installing both .xpi files, and they both work on Ubuntu jaunty Beta. My guess is the first one would be a bit more consistent w/ gnome, which also uses "crh" locale, but most likely it makes no difference.

P.S. https://answers.launchpad.net/rosetta/+question/66619

Changed in launchpad:
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions