PPA upload hangs with 1K to go

Reported by David D Short on 2008-07-25

This bug report was converted into a question: question #40230: PPA upload hangs with 1K to go on huge uploads.

70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Julian Edwards

Bug Description

"david@Chameleon:~/Desktop$ dput my-ppa *ges
Checking Signature on .changes
gpg: Signature made Fri 25 Jul 2008 09:47:24 EST using DSA key ID 4387708C
gpg: Good signature from "David Short <email address hidden>"
Good signature on /home/david/Desktop/linux_2.6.24.2-1_source.changes.
Checking Signature on .dsc
gpg: Signature made Fri 25 Jul 2008 09:47:24 EST using DSA key ID 4387708C
gpg: Good signature from "David Short <email address hidden>"
Good signature on /home/david/Desktop/linux_2.6.24.2-1.dsc.
Uploading to my-ppa (via ftp to ppa.launchpad.net):
  linux_2.6.24.2-1.dsc: done.
  linux_2.6.24.2.orig.tar.gz: 57700k/57701k"

That's pasted from the terminal. It's pretty much self-explanatory.

I've left it for a very long time, and tried it twice. Both times, I had to hit Ctrl + C.

I don't understand why it would stop at the same spot each time.

Related branches

lp:~julian-edwards/launchpad/twisted-ftp-poppy
Merged into lp:launchpad at revision 12452
Jonathan Lange (community): Approve on 2011-02-23
Leonard Richardson (community): Approve on 2011-02-22
Celso Providelo (cprov) wrote :

It has happened before and it's very likely to be a problem on your connection side. Could you, please, check if you can ftp the same 57 MiB orig somewhere else ?

Also, you know that if you orig is the same already published in ubuntu, you don't need to upload it again, right ?

Celso Providelo (cprov) wrote :

I'm converting it to a question, since there is nothing indicating that the any code is broken.

Changed in soyuz:
status: New → Invalid
Celso Providelo (cprov) wrote :

There is a issue in the server-side.

The DSC (first file) gets acknowledge by the server, probably because it's small, but the corresponding temporary file isn't created, so the upload session is blocked.

With the current log output it is very hard to identify such problem, but the interaction with directory lock files is probably the cause of the issue.

Changed in soyuz:
assignee: nobody → Celso Providelo (cprov)
importance: Undecided → High
milestone: none → pending
status: Invalid → Triaged
tags: added: soyuz-upload
Celso Providelo (cprov) wrote :

I've extended the logging and done some debug with users affected by the problem and discovered that stuck clients get a 500 FTP error (w/o any explanation string).

Also, the problem we see server-side one a while was reported in zope2 as bug #142999, but I'm not entirely sure it's related with this problem.

Celso Providelo (cprov) on 2009-08-16
tags: added: poppy
Henning Pingel (henningpingel) wrote :

I'm having exactly this problem at the moment, no matter if I use Jaunty amd64 or Karmic amd64 to upload my source package. It stops at this point:

Uploading xbmc_pvr-testing-13~hepi.orig.tar.gz: 123960k/123961k

At the same time, I am able to upload smaller source packages fine.

Valdan (valdan) wrote :

idem
I have the problem user stsso above.
and I have already uploaded other files of the same size!

Henning Pingel (henningpingel) wrote :

The problem was gone when I restartet my internet router. It was a local problem.

Curtis Hovey (sinzui) on 2010-06-01
Changed in soyuz:
assignee: Celso Providelo (cprov) → nobody

Uploading linux-maverick_2.6.35-14.19~lucid1+vaio1.tar.gz: 92849k/92850k

Uploading with normal ftp, the connection stalls, but it works with sftp method.

https://help.launchpad.net/Packaging/PPA/Uploading

Andrew Fenn (andrewfenn) wrote :

Having the same issue however although sftp seems to upload the package I still have to ctrl+c out before it says "Successfully uploaded packages" and even after that launchpad shows nothing.

This is on Maverick but i've had this problem since Hardy.

On Saturday 08 January 2011 20:52:00 you wrote:
> Having the same issue however although sftp seems to upload the package
> I still have to ctrl+c out before it says "Successfully uploaded
> packages" and even after that launchpad shows nothing.
>
> This is on Maverick but i've had this problem since Hardy.

The ctrl-c issue is a bug in maverick's dput I think.

Vincent Cheng (vincent-c) wrote :

For what it's worth, I'm facing this problem as well. I've also tried using the sftp method to upload packages to my PPA, but I always end up getting a message similar to "Unknown upload method: sftp" (I'm using dput on Debian, not Ubuntu). Is there perhaps a way to use a FTP client or similar to upload packages to a PPA?

On Tuesday 18 January 2011 02:48:23 you wrote:
> For what it's worth, I'm facing this problem as well. I've also tried
> using the sftp method to upload packages to my PPA, but I always end up
> getting a message similar to "Unknown upload method: sftp" (I'm using
> dput on Debian, not Ubuntu). Is there perhaps a way to use a FTP client
> or similar to upload packages to a PPA?

The bug is in Zope's FTP service, the workaround is to use SFTP when this
happens. We'll replace the Zope FTP server at some point and this bug will go
away.

The dput package on Ubuntu installs a /usr/share/dput/sftp.py file - maybe you
can copy it to your Debian instance although I'm surprised if it's not in
Debian's dput by now?

Vincent Cheng (vincent-c) wrote :

Thank you! It works now, although I also had to install bzr in addition to simply copying sftp.py into the right directory.

Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Julian Edwards (julian-edwards)
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
milestone: none → 11.03
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) on 2011-02-25
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2011-03-10
Changed in launchpad:
status: Fix Committed → Fix Released
Alexander Semyonov (rotuka) wrote :

I have exactly this erroneous behaviour today, when I try to upload Ruby 1.9.1 to my PPA.
So, this bug need to be reopened, I think.
I have tries to upload four times, and every time it hans with 1K to go.

Robert Collins (lifeless) wrote :

What does it show?

On Thursday 14 April 2011 23:23:49 you wrote:
> I have exactly this erroneous behaviour today, when I try to upload Ruby
> 1.9.1 to my PPA. So, this bug need to be reopened, I think.
> I have tries to upload four times, and every time it hans with 1K to go.

The FTP server we have now is a brand new piece of code completely unrelated
to the old one. I suspect at this point there are problems with people's
routers. Are you doing FTP over NAT?

I have observed 2 people uploading the same package from 2 different places -
one person had the hang, the other did not. It stronly suggests that the
problem is on the internet side of the Canonical data centre.

Scott Ritchie (scottritchie) wrote :

Perhaps the correct thing to do is make dputting by sftp the default. Unfortunately dput.cf requires configuration with your specific username -- would it be possible to have a generic sftp dput work with launchpad?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers