setPreferredEmail should require activated accounts

Bug #248518 reported by Curtis Hovey
8
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Edwin Grubbs

Bug Description

Person.setPreferredEmail() was responsible for activating accounts before Account was split from Person.
Callsites should ensure the person has an active account /before/ calling setPreferredEmail() so that
the method has less responsability..

Related branches

Curtis Hovey (sinzui)
Changed in launchpad:
status: New → Confirmed
Curtis Hovey (sinzui)
Changed in launchpad-registry:
importance: Undecided → Low
status: Confirmed → Triaged
Curtis Hovey (sinzui)
tags: added: tech-debt
removed: cleanup
Curtis Hovey (sinzui)
visibility: private → public
Revision history for this message
Curtis Hovey (sinzui) wrote :

Because Launchpad relies on the SSO and it does the password reset, Person.setPreferredEmail() should never be called with a deactivated account. The acount logic can be removed.

Changed in launchpad-registry:
milestone: none → series-10.05
tags: added: trivial
removed: registry
Changed in launchpad-registry:
assignee: nobody → Edwin Grubbs (edwin-grubbs)
status: Triaged → In Progress
summary: - setPreferredEmail activated accounts
+ setPreferredEmail should require activated accounts
Changed in launchpad-registry:
status: In Progress → Fix Committed
Revision history for this message
Ursula Junque (ursinha) wrote : Bug fixed by a commit
Changed in launchpad-registry:
milestone: series-10.05 → 10.04
tags: added: qa-needstesting
Curtis Hovey (sinzui)
tags: added: qa-ok
removed: qa-needstesting
Revision history for this message
Curtis Hovey (sinzui) wrote : Bug 248518 Fix released

Fixed released in launchpad-project 10.04.

Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers