PPA - configure: error: C compiler cannot create executables for feisty & dapper, hardy & gusty OK

Bug #235575 reported by Jeffrey Ratcliffe on 2008-05-28

This bug report was converted into a question: question #35261: PPA - configure: error: C compiler cannot create executables for feisty & dapper, hardy & gusty OK.

2
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned

Bug Description

For feisty and dapper, gtkimageview FBTFS in my PPA (https://launchpad.net/~jeffreyratcliffe/+archive), not configuring:

chmod a+x /build/buildd/gtkimageview-1.6.1/./configure
cd . && CC="cc" CXX="g++" CFLAGS="-g -Wall -O2 -fgnu89-inline" CXXFLAGS="-g -Wall -O2" CPPFLAGS="" LDFLAGS="" /build/buildd/gtkimageview-1.6.1/./configure --build=x86_64-linux-gnu --prefix=/usr --includedir="\${prefix}/include" --mandir="\${prefix}/share/man" --infodir="\${prefix}/share/info" --sysconfdir=/etc --localstatedir=/var --libexecdir="\${prefix}/lib/gtkimageview" --disable-maintainer-mode --disable-dependency-tracking --srcdir=. --disable-static
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... cc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.
make: *** [config.status] Error 77

The identical package builds in Gutsy and Hardy OK.

Where can I read the config.log?

The configure error message normally means that build-essentials is not properly installed.

Diogo Matsubara (matsubara) wrote :

After asking Celso, this bug report is better handled as a question.

Changed in soyuz:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers