support dist-upgrader-all pocket copy

Bug #231371 reported by Michael Vogt
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Colin Watson

Bug Description

Please provide copying file from "hardy-proposed" to "hardy-updates" for the "dist-upgrader-all" files.

Current the latest update-manager 0.87.27 is in hardy-updates but it does only show up in:
http://archive.ubuntu.com/ubuntu/dists/hardy-proposed/main/dist-upgrader-all/

when it should (also) be available in hardy-updates.

Because it is important to get this to our users, I would like to ask as a workaround to copy it manually in the archive for now. I subscribe ubuntu-archive (assuming they have the required permissions).

Thanks,
 Michael

Related branches

Revision history for this message
Michael Vogt (mvo) wrote :

Please make sure to copy it and not move it (the old location is referenced currently in the meta-release file).

Celso Providelo (cprov)
Changed in soyuz:
assignee: nobody → cprov
milestone: none → 1.2.6
status: New → Triaged
Celso Providelo (cprov)
Changed in soyuz:
milestone: 1.2.6 → none
status: Triaged → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Michael confirmed that we don't need manual copying, u-manager has a workaround. Unsub'ing ubuntu-archive.

Revision history for this message
Michael Vogt (mvo) wrote :

Could we please make this higher priority? it would be nice to be able to point to $distro-updates/current instead of the current approach where I manually track $distro-proposed/$explicit-version

Revision history for this message
Julian Edwards (julian-edwards) wrote :

Michael - we've talked about this and we think it's not an easy piece of work, but it also has a lot in common with features we need to include for our 3.0 release such as the unembargoing API and native source syncing. Therefore, I'll schedule it for 2.2.2!

Changed in soyuz:
importance: Undecided → High
milestone: none → 2.2.2
status: Confirmed → Triaged
Changed in soyuz:
milestone: 2.2.2 → 2.2.3
Changed in soyuz:
milestone: 2.2.3 → 2.2.4
Revision history for this message
Julian Edwards (julian-edwards) wrote :

I feel bad about slipping this again :( Sorry Michael, other stuff keeps usurping you.

Changed in soyuz:
milestone: 2.2.4 → 2.2.5
Changed in soyuz:
milestone: 2.2.5 → 2.2.6
Revision history for this message
Julian Edwards (julian-edwards) wrote :

Work is ongoing on this feature, it's mostly done via the infrastructure changes we're implementing here:
https://blueprints.edge.launchpad.net/soyuz/+spec/soyuz-delayed-copies

The finishing touches for this particular feature will be applied soon.

tags: added: feature
Changed in soyuz:
milestone: 2.2.6 → 2.2.7
Changed in soyuz:
assignee: Celso Providelo (cprov) → Julian Edwards (julian-edwards)
status: Triaged → In Progress
Revision history for this message
Julian Edwards (julian-edwards) wrote :

Progess has stalled because we found a problem with the new delayed copy mechanism, where it doesn't handle copying between pockets. We need to fix that first before this bug can be addressed.

Changed in soyuz:
milestone: 2.2.7 → 2.2.9
status: In Progress → Triaged
Revision history for this message
Matthew Revell (matthew.revell) wrote :

Retargeting to 3.0, which is the new name for 2.2.9. Haven't renamed the milestone as the 3.0 milestone is in a different series.

Changed in soyuz:
milestone: 2.2.9 → 3.0
Revision history for this message
Julian Edwards (julian-edwards) wrote :

This fails because the same version already exists; PackageUpload.verifyBeforeAccept() blows up.

Changed in soyuz:
milestone: 3.0 → none
status: Triaged → In Progress
milestone: none → pending
Revision history for this message
Michael Vogt (mvo) wrote :

Is there any news on this? I'm currently working around this by using absolute version numbers in the meta-release file, but that is far from optimal (it means that I need to updates the files manually everytime something goes from -proposed to -updates).

Revision history for this message
Julian Edwards (julian-edwards) wrote :

Michael, this turned out to be a very tough problem to solve and it stalled on the problem above. It's not getting any attention now because we have other priorities. If you want to escalate this through Robbie I'd be happy re-prioritise it.

Changed in soyuz:
status: In Progress → Triaged
Revision history for this message
Colin Watson (cjwatson) wrote :

Michael: In the meantime, I updated archive administration procedures to include copying the custom upload to -updates manually. Feel free to bug an archive administrator if you notice that this hasn't happened after a particular update.

Changed in launchpad:
assignee: Julian Edwards (julian-edwards) → nobody
summary: - support dist-upgrader pocket copy
+ support dist-upgrader-all pocket copy
Colin Watson (cjwatson)
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Revision history for this message
Colin Watson (cjwatson) wrote :

  Module lazr.jobrunner.jobrunner, line 194, in runJobHandleError
    self.runJob(job, fallback)
  Module lp.services.job.runner, line 270, in runJob
    super(BaseJobRunner, self).runJob(IRunnableJob(job), fallback)
  Module lazr.jobrunner.jobrunner, line 162, in runJob
    job.run()
  Module lp.soyuz.model.packagecopyjob, line 495, in run
    self.attemptCopy()
  Module lp.soyuz.model.packagecopyjob, line 562, in attemptCopy
    unembargo=self.unembargo)
  Module lp.soyuz.scripts.packagecopier, line 681, in do_copy
    sponsor=sponsor, packageupload=packageupload)
  Module lp.soyuz.scripts.packagecopier, line 807, in _do_direct_copy
    custom_copier.copyUpload(custom)
  Module lp.soyuz.scripts.custom_uploads_copier, line 134, in copyUpload
    package_upload.setAccepted()
  Module lp.soyuz.model.queue, line 289, in setAccepted
    for source in self.sources:
  Module storm.sqlobject, line 523, in __iter__
    for item in self._result_set:
  Module storm.sqlobject, line 505, in _result_set
    self._finished_result_set = self._finish_result_set()
  Module storm.sqlobject, line 489, in _finish_result_set
    result = self._prepare_result_set()
  Module storm.sqlobject, line 483, in _prepare_result_set
    return store.find(find_spec, *args)
  Module storm.store, line 205, in find
    self.flush()
  Module storm.store, line 503, in flush
    self._flush_one(obj_info)
  Module storm.store, line 540, in _flush_one
    result = self._connection.execute(expr)
  Module storm.databases.postgres, line 260, in execute
    result = Connection.execute(self, Returning(statement), params)
  Module storm.database, line 238, in execute
    raw_cursor = self.raw_execute(statement, params)
  Module storm.databases.postgres, line 276, in raw_execute
    return Connection.raw_execute(self, statement, params)
  Module storm.database, line 322, in raw_execute
    self._check_disconnect(raw_cursor.execute, *args)
  Module storm.database, line 371, in _check_disconnect
    return function(*args, **kwargs)
ProgrammingError: permission denied for relation packageuploadcustom

tags: added: qa-bad
removed: qa-needstesting
Revision history for this message
Colin Watson (cjwatson) wrote :

r15499 is good. Installer images are copied over from -proposed to -updates exactly as desired. (I haven't explicitly tested dist-upgrader tarballs, but they're very similar to installer images so should be fine too.)

The one flaw I can see is that it copies a little too much - namely, it also copies Rosetta translations, which fail because the copied custom upload doesn't have a .sourcepackagerelease. This is harmless, since we don't actually want or need to copy those translations. I'll prepare another follow-up branch that restricts the copied uploads to only ones in copyable_types.

Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-bad
William Grant (wgrant)
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant)
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers