Not obvious that expired questions can be reopened

Bug #226690 reported by Neal McBurnett on 2008-05-04
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

Please let us answer expired questions, as described by this question:

 https://answers.edge.launchpad.net/ubuntu/+source/gnome-panel/+question/13400

E.g. I'd like to answer this question:

 https://answers.edge.launchpad.net/ubuntu/+question/29481

When I visit my own expired questions it offers a button: "I still need an answer", which reopens it.

But on the above question, by someone else, even though it lets me edit the question itself (!), as I have done., it doesn't provide a way to reactivate the bug so it can be answered.

The question could be asked again, but the subscribers to the original question wouldn't know about it or the answer.

Also, anyone should be able to say "I still need an answer" even if they didn't ask the question. Again, we all benefit from the subscriber list.

Martin Pool (mbp) wrote :

You can reopen the question through the 'edit status' action item.

It may be that some people who could answer the question do not have permission to reopen it, and that would be a bug.

Secondly, for me on Bazaar questions, I do have permission to reopen them, but this is a bit indirect. I need to change the status to Open then add an answer. (Or is it enough to change the status to Answered from that field?)

Either way, why not leave the field at the bottom of expired questions, or at least have an obvious link where it would be to reopen it.

Changed in launchpad-answers:
status: New → Confirmed
Changed in launchpad-answers:
importance: Undecided → High
status: Confirmed → Triaged
Curtis Hovey (sinzui) on 2009-05-16
Changed in launchpad-answers:
status: Triaged → Won't Fix
Neal McBurnett (nealmcb) wrote :

Why: Seems odd to move from triaged and "high" importance to Won't Fix.

On Sun, 2009-05-17 at 15:50 +0000, Neal McBurnett wrote:
> Why: Seems odd to move from triaged and "high" importance to Won't Fix.

Because it breaks the workflow to bring a question to a conclusion.
There is a way to reopen an question that has expired, so that it can be
answered.

Curtis,

It's true it's possible to reopen questions by editing their status but this is neither very easy or very obvious.

Would you consider reopening this bug if we consider it as the UI issue "it's too slow to reopen and answer expired questions?"

By my count it's four clicks and two page loads, when it would IMO be reasonable to have the form directly on the page and then just one click to submit it.

Martin Pool (mbp) wrote :

reopening not to be rude, just so it's not lost

Changed in launchpad-answers:
status: Won't Fix → New
Curtis Hovey (sinzui) on 2009-05-18
summary: - Let us answer expired launchpad questions
+ Not obvious that expired questions can be reopened
Changed in launchpad-answers:
importance: High → Low
status: New → Triaged
tags: added: confusing-ui
Curtis Hovey (sinzui) on 2010-12-05
tags: added: questions
Hans Deragon (deragon) wrote :

This question has expired, and though I am the author of this question, I cannot edit its status.
 Is there any mean to do so in 2017?

https://answers.launchpad.net/hplip/+question/659196

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers