"Top contributor" is whack

Bug #220082 reported by Jonathan Lange on 2008-04-21
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

I recently started https://edge.launchpad.net/bzr-removable. I'm the project driver and I've written the bulk of the code.

However, at the time of filing this bug, Launchpad reports ~mwhudson as the top contributor. This is quite simply not true.

affects: launchpad-foundations → launchpad-registry
tags: added: karma registry-people
Neil Wallace (rowinggolfer) wrote :

This happened with my project also, and I found it knocked my motivation for the project.

Karl Fogel (kfogel) wrote :

Technically I don't know what is needed to fix this, but if it's going to take a while, I suggest removing "top contributor" entirely until it's fixed. It's much worse to rank contributors wrongly than to not rank them at all!

Martin Albisetti (beuno) wrote :

An intermediate step would be to not remove them, but change it to "Contributors" and not show karma.

Curtis Hovey (sinzui) wrote :

We can change the label, but the problem has more to do with non-registry apps giving inflated value for contributions. Blueprints is the worst offender. The Launchpad teams need to meet to discuss the relative value of all things that award karma.

/me is still bitter the barry had a better rating because barry created 1 blueprint for launchpad-registry.

Curtis Hovey wrote:
> We can change the label, but the problem has more to do with non-
> registry apps giving inflated value for contributions. Blueprints is the
> worst offender. The Launchpad teams need to meet to discuss the relative
> value of all things that award karma.
>
> /me is still bitter the barry had a better rating because barry created
> 1 blueprint for launchpad-registry.
>

and /me is bitter because a dentistry specific question about my project
 went to the gent who packaged the app, not me who wrote it.
the correspondent had assumed (sensibly) that the top contributer would
be the most knowledgable about the app.

Curtis Hovey (sinzui) on 2009-05-06
Changed in launchpad-registry:
importance: Undecided → Low
status: New → Triaged
Neil Wallace (rowinggolfer) wrote :

Curtis,
You are entitled to mark this as low priority.

however, consider this.

work for 12 months at approx 4 hours a day on a project. package it into your ppa, promote it and test the heck out of it.

then some dude from hungary translates the app into his language (by converting 600 of the phrases YOU wrote), and becomes the top contributer.

it would matter to you a little more then, no?

see https://launchpad.net/openmolar for an example ;)

Curtis Hovey (sinzui) wrote :

My considerations for priority, just like other launchpad team members are very fixed:
    * critical: Users are losing data or there is a security concern.
      * Assign, fix now, released after QA, do not wait for a milestone release.
    * High: The issue is a launchpad goal or an application exception.
      * Assign, commit to a release date, monitor its progress, release at the end of a milestone.
    * Low: The issue is inconvenient, but there is no one who can commit to a date to fix this by.
      * Assign and commit to a milestone only when a user has started working on the issue

This issue requires all the launchpad teams to reconcile karma. This is hard since the engineers cannot see the karma points for each task. We honestly do not know. The authors of the features may remember what was suggested, but the admin could have have entered a value by error.

Curtis Hovey (sinzui) wrote :

Actually, I do not need to see the karma point after looking at the sample data base and code. The origin of the disparity is that no karma is award for crucial activities for registering projects and team or planning a release. Karma is awarded for answers, blueprints, branches, bugs soyuz, and translations. Soyuz only award for uploads and distro acceptance. So most of the activities that we do to maintain a project do not earn karma.

Considering the tasks that I am responsible for as a maintainer, I think I should be rewarded for:
    Creating a team
    Creating a mailing list
    Creating a project
    Creating a series
    Changing a series status
    Linking a branch to a series
    Linking a series to a package
    Creating a milestone
    Marking a milestone released
    Uploading a file

Neil Wallace (rowinggolfer) wrote :

On Sat, Nov 14, 2009 at 10:58 PM, Curtis Hovey <email address hidden>wrote:
(snip)

Curtis,
thanks for your explanations and consideration of the issue. I would like to
remain top contributer on openmolar.

Perhaps I need to understand the rules and "play" the system a little. ;)

Neil.

Curtis Hovey (sinzui) wrote :

This issue is about karma, which launchpad-registry does not use. I am setting this as wont fix because we are not interested is awarding karma for registry actions. This issue might be about how other launchpad applications interact, so could be valid in launchpad bugs, code, answers, blueprints, and translations.

Changed in launchpad-registry:
status: Triaged → Won't Fix
Jonathan Lange (jml) on 2010-11-17
affects: launchpad-registry → launchpad
Changed in launchpad:
status: Won't Fix → Triaged
affects: launchpad → launchpad-registry
Curtis Hovey (sinzui) on 2010-11-22
Changed in launchpad-registry:
status: Triaged → Won't Fix
Jonathan Lange (jml) wrote :

This shuffling of bug statuses is ridiculous.

There is a bug in Launchpad: the "top contributor" list is frequently very misleading. I don't care which sub-project it lives in, as long as it stays open until it is eventually fixed and as long as Launchpad developers and contributors can find it.

Curtis Hovey (sinzui) wrote :

What kind of patch will I accept? You made it clear registry karma for parity is not acceptable. If the solution is to remove everyone's karma, then lets have a bug about removing karma.

Jonathan Lange (jml) wrote :

A patch against lp:launchpad that fixes the bug? It doesn't matter whether it's against code in lp.registry or lp.bugs or whatever. It's a bug in Launchpad that ought to be fixed in Launchpad.

Separately,
  - just because neither of us can imagine a solution right now doesn't mean that we should not fix the bug
  - I don't recall making it clear that "registry karma for parity" is not acceptable

Curtis Hovey (sinzui) on 2010-11-22
Changed in launchpad-registry:
status: Won't Fix → Triaged
tags: added: ui
removed: registry-people
tags: added: contribution
Neil Wallace (rowinggolfer) wrote :

I've moved my code hosting elsewhere. Hopefully to a place where coders are appreciated.

Martin Pool (mbp) wrote :

Neil, I'm sorry to hear that but I can understand how you found this frustrating.

At the moment karma is an indicator of activity but it should not be taken too seriously because the values are not precisely aligned with contribution.

I think Karl and Beuno's comments 2 and 3, basically just removing the implication that the mentioned contributors are the ordered top contributors, would be a good move.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers