OOPS processing Mantis bugwatches

Bug #218384 reported by Diogo Matsubara on 2008-04-16
12
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Tim Penhey

Bug Description

As seen in OOPS-834CCW59, when something goes wrong processing Mantis bugwatches, instead of logging the error, we're raising an OOPS trying to call an non-existent self.warning() method. The exception is similar to bug 194039

Exception type AttributeError
Exception value 'Mantis' object has no attribute 'warning'

Related branches

Changed in malone:
importance: Undecided → High
Björn Tillenius (bjornt) wrote :

Reducing the priority to medium, since this seems to affect only a small number of bug watches.

Changed in malone:
importance: High → Medium
milestone: none → 1.2.5
status: New → Confirmed
Changed in malone:
milestone: 1.2.5 → 1.2.6
Changed in malone:
milestone: 1.2.6 → none
Gavin Panella (allenap) on 2010-01-15
tags: added: story-reliable-bug-syncing
Changed in launchpad:
importance: Medium → Critical
Tim Penhey (thumper) on 2011-02-28
Changed in launchpad:
assignee: nobody → Tim Penhey (thumper)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
milestone: none → 11.03
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) on 2011-03-01
tags: added: bad-commit-12487 qa-bad
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-bad
Tim Penhey (thumper) on 2011-03-02
tags: added: qa-untestable
removed: qa-needstesting
William Grant (wgrant) on 2011-03-02
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers