Report XML SyntaxError in XPI files as TranslationFormatSyntaxError

Bug #216149 reported by Jeroen T. Vermeulen on 2008-04-12
4
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Jeroen T. Vermeulen

Bug Description

An XML parser error in XPI is reported as an unexpected exception:

https://pastebin.canonical.com/4120/

It should be reported as a syntax error (TranslationFormatSyntaxError), so the user gets proper feedback.

Changed in rosetta:
importance: Undecided → High
Diogo Matsubara (matsubara) wrote :

Moved the URL from a Librarian file to pastebin.
Is this exception recorded as an OOPS? How does the user get feedback?

description: updated
Changed in rosetta:
status: New → Confirmed
Alexander Sack (asac) wrote :

maybe paste the actual xml that is invalid here? we probably want to carry that to upstream translation group if its a bug in the .xpi's imported.

Jeroen T. Vermeulen (jtv) wrote :

Diogo: no, this is not recorded as an oops, only as error output on error-reports. Our scripts don't use the oops infrastructure yet.

Alexander: we don't know, and this bug is probably not the best place for that. But if upstream has tools to validate this stuff, we could perhaps add a reference to that somewhere. We already do for gettext.

Jeroen T. Vermeulen (jtv) wrote :

It turns out this problem is caused only by parse errors in install.rdf, so we see it while trying to retrieve the last translator. Syntax errors in DTD aren't detected at all (bug 353664).

Changed in rosetta:
assignee: nobody → jtv
status: Triaged → In Progress
Changed in rosetta:
milestone: none → 2.2.4
Jeroen T. Vermeulen (jtv) wrote :

Fixed in RF 8155

Changed in rosetta:
status: In Progress → Fix Committed
Changed in rosetta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers