Register branch page should make it clear registration is not pre-requisite for working on a project

Bug #215798 reported by Matthew Revell on 2008-04-11
6
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Matthew Revell

Bug Description

mars says:
" Neither the 'Code' help popup nor the wiki Hosted Branch pages actually tell me if I should/have to register a branch before pushing to Launchpad.
 I can see one mention of 'register' in the first sentence of https://help.launchpad.net/FeatureHighlights/BugBranchLinking but if I come to the 'Register a branch' page first, there is nothing to tell me that registering is *not* a pre-requisite for working on a project.
 I at least expected a sentence in the main body content, below the header, that says "You need to register a branch if you want to link bugs or blueprints to it.""

Related branches

Changed in launchpad-bazaar:
assignee: nobody → matthew.revell
importance: Undecided → Medium
milestone: none → 1.2.5
Māris Fogels (mars) wrote :

Here is little drama that played out in my head:

I wanted to upload a branch for the Zope3 project with some of my custom work in it. I went to the Zope3 project page, then went to the "Code" tab, expecting.... ? Code?

I have very little info on that page - nothing that looks like branches, so I looked at the Actions, and see "Register branch" - ah ha! Maybe there I will find out how my Zope3 branch can be linked with the project!

So I am on the "Register a Branch" page - ok, do I have to do this? Is "Registering a Branch for this project" the same as "Uploading a Branch for this project"? I don't know. And *that* is where I got confused.

Does the "Help" popup say? No. Does the "Help" popup take me to the nice long wiki page explaing where I am, and what I am supposed to do here? No.

Ok, I have to find the Wiki pages link (The FAQ link at the bottom maybe? I'll try it). I see a search field, so I search the wiki for "register branch". Nothing? Ok, there is a "Find a Page" link in the Actions box, I'll try that (again). Ah, Full Text Search, that brings back something. And so on...

Māris Fogels (mars) wrote :

My personal "Code" page doesn't say anything either. How do I upload a branch? Do I need to register a new branch? (Why does it say my branch will be "+junk"?)

It says "You can use Launchpad as a registry for Bazaar branches" - cool (I think - what's a registry?). But how? I don't even get a link to follow?

Joey Stanford (joey) wrote :

manager override - changing this to 1.2.6

Changed in launchpad-bazaar:
milestone: 1.2.5 → 1.2.6
Tim Penhey (thumper) on 2008-07-03
Changed in launchpad-bazaar:
milestone: 1.2.6 → 1.99
Jonathan Lange (jml) on 2008-07-08
Changed in launchpad-bazaar:
status: New → Triaged
Matthew Revell (matthew.revell) wrote :

Untargeting. Will pick up during the next milestone. Although the register branch page now makes it clear that selecting a project is optional, it doesn't tell you what you miss out on if you don't.

So, I'll use the new help system to insert the appropriate help text during the next milestone.

Changed in launchpad-bazaar:
milestone: 1.99 → none
status: Triaged → Confirmed
Jonathan Lange (jml) wrote :

Related to bug 221343.

Changed in launchpad-code:
status: Triaged → In Progress
Changed in launchpad-code:
milestone: none → 3.1.10
Changed in launchpad-code:
status: In Progress → Fix Released

How to select a project when registering a branch?
When I register a branch, I can select only two types of owner: me or my team. Should my project appear in this list?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers