Non-existent distribution series source package shouldn't have upstream links

Reported by Matthew Paul Thomas on 2008-03-20
12
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Curtis Hovey

Bug Description

At the time of writing, <https://launchpad.net/ubuntu/breezy/+source/warzone2100> says "There is no current release of this source package in The Breezy Badger." But then it goes on to list a link between that non-existent package and an upstream project series!

Non-existent packages shouldn't have upstream links (especially non-existent packages in already-released distribution series).

Dennis Schridde (devurandom) wrote :

Till this bug is solved correctly, can someone please remove the invalid Breezy link from https://launchpad.net/warzone2100/ ?

It seems I am unable to remove the link mentioned at https://launchpad.net/ubuntu/breezy/+source/warzone2100 myself, i.e. via https://launchpad.net/ubuntu/breezy/+source/warzone2100/+edit-packaging or similar. I guess someone with database access is needed...

Dennis Schridde (devurandom) wrote :

Where do I need to send this so that finally something happens?
If it is easier for you, you could also purge all package links of warzone2100 from the database. I can easily recreate them, I think.

Stéphane Loeuillet (leroutier) wrote :

Bug #156118 (mine) shows the same problem with non existant 'swfdec' package links for gutsy and hardy.

Duping mine on this one

Changed in launchpad:
status: New → Confirmed
Dennis Schridde (devurandom) wrote :

Another week passed since comment #2 and the links are still present.

Dennis Schridde (devurandom) wrote :

And another week...

Dennis Schridde (devurandom) wrote :

Sorry about the email-spam, I filed https://bugs.launchpad.net/launchpad/+bug/222849 on that issue.

Dennis Schridde (devurandom) wrote :

7 weeks, and the links are still present...

Curtis Hovey (sinzui) on 2009-10-20
affects: launchpad-foundations → launchpad-registry
Changed in launchpad-registry:
importance: Undecided → Low
status: Confirmed → Triaged
Curtis Hovey (sinzui) on 2009-11-24
tags: added: package-link
Changed in launchpad-registry:
milestone: none → 3.1.11
milestone: 3.1.11 → 3.1.12
importance: Low → High
Curtis Hovey (sinzui) on 2009-12-10
Changed in launchpad-registry:
assignee: nobody → Curtis Hovey (sinzui)
status: Triaged → In Progress
Curtis Hovey (sinzui) on 2009-12-12
Changed in launchpad-registry:
milestone: 3.1.12 → 3.1.13
Curtis Hovey (sinzui) on 2009-12-15
Changed in launchpad-registry:
status: In Progress → Triaged
assignee: Curtis Hovey (sinzui) → nobody
Curtis Hovey (sinzui) on 2010-01-11
Changed in launchpad-registry:
assignee: nobody → Curtis Hovey (sinzui)
status: Triaged → In Progress
Curtis Hovey (sinzui) wrote :

Fixed in launchpad-devel r10161.

Changed in launchpad-registry:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2010-01-28
Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers