Sort translatable packages by popcon popularity and nearness to completion

Bug #20 reported by Johan Walles on 2004-12-31
14
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

You could suggest which one of the available packages that is most in need of a translation.

IMO, two factors make a package important to translate:
1. There are few phrases left before the package is completely translated.
2. The package is used by lots of people.

You already have data about the first one. Since Ubuntu is roughly == Debian, the second one could be taken from the Popularity Contest ("http://popcon.debian.org/").

Give each package a score of ((popularity + 1) / strings_left). Then sort the Translatable Applications list at "https://launchpad.ubuntu.com/rosetta" from higher scores towards lower.

The "popularity + 1" is to avoid giving packages that nobody uses a score of zero. The reason for using division rather substraction is that (popularity + 1) and strings_left have different dimensions and can't really be substracted from each other (just like substracting a weight from a speed wouldn't give you anything useful).

When your package list grows longer I think you'll have to do something like this, and I think the above algorithm is a good way of doing it.

The most wanted translations list will be different for each language.

Carlos Perelló Marín (carlos) wrote :

I just created a placeholder for the spec that will define this feature. You can see it at: https://launchpad.net/products/rosetta/+spec/sorting-translation-resources

I cannot give you a date when it will be implemented but the first step is to write the spec and, after that, decide when will be implemented.

Changed in rosetta:
assignee: nobody → carlos
status: New → Accepted
Changed in rosetta:
assignee: carlos → nobody
Jeroen T. Vermeulen (jtv) wrote :

Bug 300297 now addresses the combined sorting, based on priority and untranslated messages. Setting priorities automatically is a separate job.

Changed in rosetta:
status: Confirmed → Invalid
Johan Walles (walles) wrote :

Jeroen, if bug 300297 deals with only half of this issue, how does that make this request invalid?

I don't mind you setting this request to Invalid, but in that case you have to explain *why* this request has no merit.

Changed in rosetta:
status: Invalid → New
Johan Walles (walles) wrote :

Ubuntu nowadays has a Popularity Contest of its own: http://popcon.ubuntu.com/
Machine readable results are in: http://popcon.ubuntu.com/all-popcon-results.txt.gz

Because in practice, it's going to be Ubuntu guys updating the priority themselves (or at least they should be). What they are going to base the priority on (be it popcon, manual work, or whatever) is outside of the scope of Launchpad Translations (thus, it's not a bug in Launchpad itself, it's mostly a process change: we provide them with a relatively free form priority field they can use in whatever way they desire; or, if you prefer it, we can make it a 'won't fix' as well). Once we have APIs for this, they'd be able to write their tools to do it automatically for them as well (but you can see how this is a different problem even if one depends on the other).

Changed in rosetta:
status: New → Invalid
tags: added: iso-testing
tags: removed: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers