launchpad's "report a bug" hangs in bug data processing

Bug #1996471 reported by Tomislav

This bug report was converted into a question: question #703856: launchpad's "report a bug" hangs in bug data processing.

10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Undecided
Unassigned

Bug Description

I encountered a bug in nautilus and wanted to report it by running "ubuntu-bug nautilus". A browser window was opened with the message "Please wait while bug data is processed. This page will refresh every 10 seconds until processing is complete." being displayed for 10 minutes or so.

I would expect it to complete processing within 10-30s: it looks like it got stuck.

Tags: bot-comment
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Libera.chat.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1996471/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Paul White (paulw2u)
affects: ubuntu → apport (Ubuntu)
affects: apport (Ubuntu) → launchpad
Revision history for this message
Tomislav (hefest) wrote :

I see that importance is "undecided": given that any issues cannot be reported using "ubuntu-bug" (still seems to be the case), I would say importance is rather high.

Is there a workaround which allows simple collection and uploading of important data to use until this bug is resolved?

Revision history for this message
Colin Watson (cjwatson) wrote :

Converting this to a question since it's an operational issue.

Changed in launchpad:
status: New → Invalid
Revision history for this message
Sergey Ivanov (icegood1980) wrote :

collecting of data in browser became infinite

This is the result of hardware and optional installer/upgrader that we collected:
{
  "Version": "22.10",
  "OEM": {
    "Vendor": "HP",
    "Product": "Victus by HP Laptop 16-e0xxx",
    "Family": "103C_5335M7 HP VICTUS"
  },
  "BIOS": {
    "Vendor": "AMI",
    "Version": "F.15"
  },
  "Arch": "amd64",
  "HwCap": "x86-64-v3",
  "GPU": [
    {
      "Vendor": "10de",
      "Model": "1f9d"
    },
    {
      "Vendor": "1002",
      "Model": "1638"
    }
  ],
  "RAM": 23.9,
  "Partitions": [
    24.8,
    19,
    1.9,
    9.5,
    6,
    4.7,
    0.8,
    47.5,
    174.7,
    208.2,
    684.8,
    706.4,
    109.3
  ],
  "Screens": [
    {
      "Size": "355mmx200mm",
      "Resolution": "1920x1080",
      "Frequency": "60.01"
    }
  ],
  "Autologin": true,
  "LivePatch": false,
  "Session": {
    "DE": "ubuntu:GNOME",
    "Name": "ubuntu",
    "Type": "x11"
  },
  "Language": "C",
  "Timezone": "Europe/Kyiv"
}

Changed in launchpad:
status: Invalid → Confirmed
Revision history for this message
Sergey Ivanov (icegood1980) wrote :
Revision history for this message
Colin Watson (cjwatson) wrote :

The machine where these were being processed is having trouble uploading files to the librarian for unknown reasons, and often crashes while trying to do so. I've configured our Celery workers to pick up this type of job, which should make them work much better much more often (and typically with lower latency as well).

I haven't yet turned off the old cron job, so there may still be some failures, but with a lower frequency.

Revision history for this message
Colin Watson (cjwatson) wrote :

This is also still an operational issue rather than a software bug, so closing again in favour of the linked question.

Changed in launchpad:
status: Confirmed → Invalid
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.