Oops deactivating account when the account has a conjoined bugtask assigned to it

Bug #193983 reported by Diogo Matsubara
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Graham Binns

Bug Description

Steps to reproduce:
1. Logged in as Sample Person, open http://bugs.launchpad.dev/debian/sarge/+source/mozilla-firefox/+bug/3/+editstatus
2. Set the Remote Watch to: None, the stauts of the bug is updated manually
3. Open http://bugs.launchpad.dev/debian/sarge/+source/mozilla-firefox/+bug/3/+editstatus again and assign it to Sample person
4. Open http://launchpad.dev/~name12/+deactivate-account
5. Enter the password and click "Deactivate My Account"
6. OOPS-781C529 ConjoinedBugTaskEditError This task cannot be edited directly, it should be edited through its conjoined_master.

This happens because the code to deactivate account un-assigns all bugs from the account that is being deactivated.
This might be solved by fixing bug 106338

Graham Binns (gmb)
Changed in malone:
assignee: nobody → gmb
milestone: none → 1.2.3
Graham Binns (gmb)
Changed in malone:
status: New → In Progress
Revision history for this message
Graham Binns (gmb) wrote :

Landed in mainline r5767.

Changed in malone:
status: In Progress → Fix Committed
Changed in malone:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers