PPA packages fail to upload but build successfully

Bug #192713 reported by Chris Irwin
6
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Julian Edwards
Mactel Support
Undecided
Unassigned
apt (Ubuntu)
Undecided
Unassigned

Bug Description

Packages that built successfully "fail to upload" for unknown reasons.

This occurs with packages in two PPAs at least (a team and my personal):

https://launchpad.net/~mactel-support/+archive/+builds?build_text=&build_state=uploadfail
https://launchpad.net/~chrisirwin/+archive/+builds?build_text=&build_state=uploadfail

I have re-versioned a known-good package that has built before and encountered the same results.

Revision history for this message
Chris Irwin (chrisirwin) wrote :
Revision history for this message
Chris Irwin (chrisirwin) wrote :

Note that the 2.6.22 kernel in ~mactel-support had successfully built and uploaded in ~chrisirwin prior.

Celso Providelo (cprov)
Changed in soyuz:
milestone: none → 1.2.3
status: New → Triaged
Celso Providelo (cprov)
Changed in soyuz:
assignee: nobody → adconrad
importance: Undecided → High
Celso Providelo (cprov)
Changed in soyuz:
assignee: adconrad → cprov
Revision history for this message
Amit Kucheria (amitk) wrote :

Intel is also affected by this "fail to upload" problem:

They reported seeing the following error in their email:

"05:17:52 ERROR Unhandled exception processing upload

 -> http://launchpadlibrarian.net/12127324/rdrcaxMIGjVfFL55o0JtpByqM8p.txt"

They have asked for explanations for this problem

Revision history for this message
Amit Kucheria (amitk) wrote :

Canonical Kernel team is also seeing the same problems with Ubuntu Hardy kernel builds in the PPA.

Revision history for this message
Celso Providelo (cprov) wrote :

This problem was workarounded in production and the definitive fix is being sorted and will be released ASAP.

Feel free to ask a archive-admin (or me) to re-process the failed-to-upload build results (supplying the build-failure notification message) or to simply retry the build yourself.

Sorry for this inconvenience.

Celso Providelo (cprov)
Changed in soyuz:
assignee: cprov → julian-edwards
importance: High → Critical
status: Triaged → In Progress
Revision history for this message
Celso Providelo (cprov) wrote :

I'm opening a bugtask in apt because the whole problem is caused by a memory leak (opened files left behind) in apt_inst.debExtractArchive method.

Revision history for this message
Julian Edwards (julian-edwards) wrote :

Fixed in RF 5849 for Soyuz. The code now uses the backported python-apt fix.

The problem was originally worked around in production by increasing the ulimit for files but we'll probably cherry pick this anyway.

Changed in soyuz:
status: In Progress → Fix Committed
Revision history for this message
Julian Edwards (julian-edwards) wrote :

Fix was cherry picked.

Changed in soyuz:
status: Fix Committed → Fix Released
Changed in mactel-support:
status: New → Fix Released
Changed in apt:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers