snap builds via bsi use the deb rather than snap of snapcraft

Bug #1867689 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2020-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned

Bug Description

A few instances exist of launchpad using the deb of snapcraft rather than the snap.

https://launchpad.net/~build.snapcraft.io/+snap/f575d29e94f650a871d01c059930838d/

It appears this may be related to the rollout of the new build button inside the snapcraft store page.

I haven't been able to reproduce it, but others have had the same problem.

https://forum.snapcraft.io/t/build-error-on-remote-build-works-locally/16023
https://forum.snapcraft.io/t/build-snapcraft-io-build-failing-due-to-ancient-snapcraft/15990

Colin Watson (cjwatson) wrote :

Let's keep this bug open for better logs about all this in Launchpad so that we spend less time flailing; but this is a bug in some support code for the new snapcraft.io stuff. I've re-filed this as https://github.com/canonical-web-and-design/canonicalwebteam.launchpad/issues/13.

Tom Wardill (twom) wrote :

As an update, code to fix this appears to have landed. Just awaiting production rollout.

Tom Wardill (twom) wrote :

New update, this is now released!

Changed in launchpad:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.