Project group "display name" is redundant with "title"

Bug #1853 reported by Matthew Paul Thomas on 2005-08-23
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
William Grant

Bug Description

We currently expect people creating/editing project groups to enter both a "title", being "the full name of the project, [which] can contain spaces, special characters etc"; and an "appropriately capitalised" "display name", of which examples include "the Apache Project", "the Mozilla Project", and "the GiMP [sic] Project".

All those display name examples are of the form "the %title Project", making the display name field redundant. People are going to be unnecessarily confused about what the distinction between display name and title should be. And you can't "appropriately capitalise" the word "the" anyway, because it might be used at the start of a sentence or it might not.

"Display name" should be dropped from the data model, and any existing callsites used should print either "the $title Project" or "The $title Project" as appropriate for their setting.

(The equivalent for projects themselves is bug 4449.)

Related branches

description: updated
David Allouche (ddaa) wrote :

I agree with your rationale, but disagree with your conclusion.

First, there are places where a distinct title is useful. For example (if we follow source package naming) we could have name="firebird" displayname="FireBird" and title="FireBird Database" (as opposed to browser). I find it often useful to use the title to clarify the name a bit. For example displayname="Osiris" does not tell you much, but title="Osiris - Host Integrity Monitor" can really help reading long lists like in <https://launchpad.net/products?text=network>.

Also, in my understanding, the one item that's not well defined is _title_. Displayname is very clearly meant to be the actual name of the project, with proper capitalisation, while name is constrained by url policies. An example could be name="texmacs" displayname="TeXmacs". The capitalised X in the middle of the word is part of the proper name of the project, or name="gnulinux" title="GNU/Linux".

I think title and displayname are both useful, but the help text could be very much improved. From a data input perspective the one that's easy to explain and understand is displayname.

The help text should be fixed to make sense. That's true for most Registry input forms anyway.

David Allouche (ddaa) wrote :

The previous comment demonstrate a linkification bug, too...

Christian Reis (kiko) wrote :

That's bug 1634, which I'm about to fix.

Matthew Paul Thomas (mpt) wrote :

Actually, I reported this bug because I was cleaning up the help text and realized that I couldn't make it make sense. Suggestions? It seems like you're proposing Title become "Disambiguated Display Name". That *might* be necessary for products, e.g. "Epiphany browser" vs. "Epiphany game" (though I'd still think that was a too-low benefit-to-cost ratio, especially since the package name already disambiguates search results). But I don't think it's at all necessary for projects.

Dafydd Harries (daf) wrote :

Matthew, may I suggest you write a spec for this? Doing so seems to have worked well for FixingProjects.

Dafydd Harries (daf) on 2006-02-09
Changed in launchpad:
status: Unconfirmed → Confirmed
description: updated
Curtis Hovey (sinzui) wrote :
Changed in launchpad-registry:
importance: Medium → Wishlist
status: Confirmed → Triaged
Curtis Hovey (sinzui) on 2009-05-13
tags: removed: registry ui
Curtis Hovey (sinzui) on 2012-12-30
tags: added: projectgroups
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
tags: added: qa-needstesting
Changed in launchpad:
status: Triaged → Fix Committed
William Grant (wgrant) on 2015-07-08
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant) on 2015-07-10
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers