GitHub bug watches fail due to "id" vs. "number" confusion

Bug #1824728 reported by Walter Lapchynski on 2019-04-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Colin Watson

Bug Description

This bug on Calamares:
https://bugs.launchpad.net/ubuntu/+source/calamares/+bug/1801440
includes a link to the upstream bug:
https://github.com/calamares/calamares/issues/712
which Launchpad is having problems importing with an unknown error:
Unknown error (Launchpad couldn't import bug)

However, the same bug tracker has no problems elsewhere:
https://bugs.launchpad.net/ubuntu/+source/calamares/+bug/1820960
https://bugs.launchpad.net/ubuntu/+source/calamares/+bug/1801498

Related branches

Colin Watson (cjwatson) wrote :

This is e.g. OOPS-c8dd0400fd03ea651091bdf639a870f7, which looks like some kind of logic error in the GitHub import logic:

Traceback (most recent call last):
  Module lp.bugs.scripts.checkwatches.remotebugupdater, line 140, in updateRemoteBug
    self.remote_bug))
  Module lp.bugs.externalbugtracker.github, line 198, in getRemoteStatus
    remote_bug = self.bugs[int(bug_id)]
KeyError: 712

Changed in launchpad:
importance: Undecided → Critical
status: New → Triaged
tags: added: bugwatch lp-bugs oops
Colin Watson (cjwatson) wrote :

Hmm. I think the problem is that we're using the "id" field of the issue object returned by GitHub when we should be using the "number" field. I'm slightly confused about how this ever worked (which I'm sure it did at some point) - did GitHub change something or did we get lucky somehow?

Colin Watson (cjwatson) on 2019-04-15
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
summary: - Unknown error (Launchpad couldn't import bug
+ GitHub bug watches fail due to "id" vs. "number" confusion
Colin Watson (cjwatson) on 2019-04-16
Changed in launchpad:
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed

Will the affected bug reports self heal their watches? I've seen no change so far.

Colin Watson (cjwatson) wrote :

I haven't QAed or deployed the fix yet, so that's not surprising.

Colin Watson (cjwatson) on 2019-04-16
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) wrote :

Deployed now. It may take a while (could be as much as a week, I think, since the bug watch scheduler backs off on failures), but the watches should self-heal. I've reset the ones mentioned in this bug report and in its duplicate.

Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers