oops when displaying sshkeys page (presumable related to encoding)

Bug #1798046 reported by Junien Fridrick
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Critical
William Grant

Bug Description

Keys in question :
https://launchpad.net/%7Eluis.lopez/+sshkeys

Error ID: OOPS-dd4ae8827caab6f60c0f879448564578

UnicodeDecodeError: 'ascii' codec can't decode byte 0xdc in position 0: ordinal not in range(128)<br />

Tags: oops qa-ok ssh

Related branches

Revision history for this message
William Grant (wgrant) wrote :

The problem is that there's an "A" missing from the start of the key text. getNS then returns a whole lot of garbage rather than "ssh-rsa".

Changed in launchpad:
status: New → Triaged
importance: Undecided → Critical
tags: added: oops ssh
William Grant (wgrant)
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant)
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson)
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.