Unable to delete repository

Bug #1793266 reported by Alkis Georgopoulos on 2018-09-19
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Colin Watson

Bug Description

Hi, I go to https://code.launchpad.net/~alkisg/epoptes/+git/gsoc2018/+delete
I press the Delete button,
but I keep getting the following error:

Timeout error
Sorry, something just went wrong in Launchpad.
We’ve recorded what happened, and we’ll fix it as soon as possible. Apologies for the inconvenience.
Trying again in a couple of minutes might work.
(Error ID: OOPS-e9f7efb3ba3a49bef6802a1856978481)

...please delete that repository for me. Thank you.

Related branches

description: updated
Alkis Georgopoulos (alkisg) wrote :

Hi, I tried again today, still the same issue, that repository isn't deleteable and needs to be removed manually by some administrator.

Colin Watson (cjwatson) on 2019-01-30
tags: added: git lp-code oops timeout
Colin Watson (cjwatson) wrote :

It's odd that the delete from Job is so slow, since selecting from it is quite quick on staging. Perhaps there are some badly organised indexes or something.

If we can't fix the delete to be fast, we may have to invent a "deleting" status for Git repositories, and then make this asynchronous.

Changed in launchpad:
importance: Undecided → Critical
status: New → Triaged
Colin Watson (cjwatson) on 2019-03-21
Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Colin Watson (cjwatson)
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Colin Watson (cjwatson) wrote :

2019-03-22 18:02:54,291 INFO 2210-01-0 applied just now in 0.1 seconds

tags: added: qa-ok
removed: qa-needstesting
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Colin Watson (cjwatson) on 2019-04-02
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) wrote :

Could you please give this another try? We may still need the asynchronous deletion, but in the meantime we added some more database indexes yesterday (https://code.launchpad.net/~cjwatson/launchpad/more-job-indexes/+merge/367063) which may well have helped.

Denis Smirnov (dennwc) wrote :

It fixed the issue for me, thanks!

Alkis Georgopoulos (alkisg) wrote :

I tried it on two repositories that I couldn't delete.
Both were imports of external repositories.

Both were successfully deleted just now!
Thanks a lot!

René Fritze (renemilk) wrote :

I can also confirm this working on a previously failing repo: https://code.launchpad.net/~pymor/pymor/+git/pymor

Colin Watson (cjwatson) wrote :

It sounds like the indexes did the trick. If we come across new cases where deletion performance is a problem, please file a new bug and we can look into it there.

Changed in launchpad:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions