New PPA signing key won't be available on keyserver.ubuntu.com even after waiting for a day

Bug #1782354 reported by LinTaro on 2018-07-18
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Colin Watson

Bug Description

I created my first ppa yesterday, I tried adding the ppa to a my Ubuntu 18.04 LTS machine and I noticed the repository can't be added because it cannot find the PPA signing key.

According to my PPA's page (https://launchpad.net/~lintaro/+archive/ubuntu/mcomix), the key should be
https://keyserver.ubuntu.com/pks/lookup?fingerprint=on&op=index&search=0xED03DD52031A126373CA97AFB6C349658F6C7DAB

But that just says "No keys found."

According to https://answers.launchpad.net/launchpad/+question/670706, some people face the same problem.

Tags: ppa Edit Tag help
André Düring (starterpage) wrote :
tags: added: ppa
Changed in launchpad:
status: New → Confirmed
kirill (kirill-yalta) on 2018-07-18
Changed in launchpad:
assignee: nobody → kirill (kirill-yalta)
kirill (kirill-yalta) on 2018-07-18
Changed in launchpad:
status: Confirmed → Fix Committed
Colin Watson (cjwatson) on 2018-07-18
Changed in launchpad:
assignee: kirill (kirill-yalta) → nobody
status: Fix Committed → Confirmed
Jake Harr (jakar) wrote :

This has been fixed for me. Hopefully it is for others as well. Thanks.

André Düring (starterpage) wrote :

Not yet :/ will report again in ~ 10g

Also has been fixed for me.

Simon Déziel (sdeziel) wrote :

Works for me as well, many thanks.

Colin Watson (cjwatson) wrote :

The underlying problems aren't completely fixed yet, so I'm leaving this bug open. We temporarily reconfigured things so that we could push keys generated over the last two weeks to a different set of keyservers that has fewer operational problems. However, until the deployment of those keyservers is tidied up, Launchpad hasn't been pointed at them permanently, and so newly-generated keys may still go missing.

Once the new keyservers are properly deployed, we'll do another catch-up push, and then hopefully things should be stable from there.

André Düring (starterpage) wrote :

it works now also for me. Thanks for your help

Still not working for me. I'm not sure if under the current workaround whether my key should appear at https://keyserver.ubuntu.com/ or not. Currently it does not appear even after submitting it again and waiting a while. I am also unable to import the fingerprint in Launchpad.

Joshua, I think you must be talking about a user key, not a PPA signing key. That isn't really something we can work around in Launchpad; the keyserver has to be properly fixed before that will work.

Colin Watson (cjwatson) wrote :

This is working much better now; there was a buggy rewrite rule that caused adds to be dropped on the floor, which is now fixed. All PPA signing keys from the relevant time period are now on the keyserver, but if you tried to upload a user key and it vanished then you'll need to upload it again.

Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Released
importance: Undecided → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers