Tell who subscribed you to a blueprint in the notification mail

Reported by Emilio Pozuelo Monfort on 2007-12-19
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

I just received this mail:

You are now subscribed to the blueprint drinking-from-the-firehose -
Drinking from the Firehose.

--
  https://blueprints.edge.launchpad.net/ubuntu/+spec/drinking-from-the-firehose

It should have said who subscribed me, for example:
"You are now subscribed to the blueprint drinking-from-the-firehose -
Drinking from the Firehose as Foo subscribed you"
, or
"Foo subscribed you to the following blueprint and hence you are subscribed to it: drinking-from-the-firehose -
Drinking from the Firehose."

See also bug 137846, about restricting who can subscribe you to a blueprint.

description: updated
Changed in blueprint:
importance: Undecided → Medium
status: New → Confirmed
Diogo Matsubara (matsubara) wrote :

I'm closing this one. While trying to reproduce bug 137846, I got the 2 notifications like:

From: Sample Person <email address hidden>
Date: Tue, 06 May 2008 19:22:30 -0000
To: <email address hidden>
Subject: [Blueprint media-integrity-check] CD Media Integrity Check
Reply-To: Sample Person <email address hidden>
X-Spambayes-Classification: ham; 0.00

Blueprint changed by Sample Person:

    Assignee: (none) => No Privileges Person

--
  CD Media Integrity Check
  http://blueprints.launchpad.dev/ubuntu/+spec/media-integrity-check

One was addressed to Sample Person and the other to No-Privileges Person, So it clearly states who did what change and notifies both parties.

Changed in blueprint:
status: Confirmed → Fix Released
Emilio Pozuelo Monfort (pochu) wrote :

That seems to be the case if you are subscribed because you are the assignee. That doesn't still fix this bug because:
a) the info message (you are now subscribed to foo) doesn't say why as bug mail says (you are subscribed because you are subscribed to a duplicate bug, or whatever)
b) if you are just subscribed to a blueprint, instead of put as the assignee, there will be no info

I've just asked on IRC for someone to subscribe me to a blueprint, and this is the message I got. As you can see, I can't guess why I'm subscribed:

You are now subscribed to the blueprint packaging-tools-usability -
packaging-tools-usability.

--
  https://blueprints.edge.launchpad.net/ubuntu/+spec/packaging-tools-usability

Changed in blueprint:
status: Fix Released → New
status: New → Confirmed
Diogo Matsubara (matsubara) wrote :

You're conflating issues here. In the initial report you wanted to know who subscribed you. Now you want to know why you're subscribed to the blueprint. Can you define what exactly is confusing you?

If you are assigned a role in the blueprint (Assignee, Approver, Drafter) you get notifications and the email you get is the status change.
If you are subscribed by someone else, the email you get is mailed from that person (in the email header From: Foo Bar), so I think it's a bit redundant to repeat that in the body of the email. Setting low importance for now until we have more evidence that this confusion is more generally widespread.

Changed in blueprint:
importance: Medium → Low
status: Confirmed → Incomplete

Diogo Matsubara wrote:
> You're conflating issues here. In the initial report you wanted to know
> who subscribed you. Now you want to know why you're subscribed to the
> blueprint. Can you define what exactly is confusing you?

This bug was about the first issue (who subscribed me). The second would be
nice, but that's a different thing yup.

> If you are subscribed by someone else, the email you get is mailed from that person

Bah, I missed that. I've verified it and it indeed is there. So from my POV this
can be closed.

 status invalid

Changed in blueprint:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers