Wrong git MP prerequisite repo causes OOPS

Bug #1771118 reported by Alberto Donato on 2018-05-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Colin Watson

Bug Description

When setting a prerequisite repository for a GIT MP, if the repo is incorrectly specified and includes the branch name (such as "~user/project/+git/repo:branch") an OOPS is caused, rather than a useful error message.

An example of the issue is OOPS-8a99dcdc0c4432fd6f3968d0b4a88e4a

Related branches

Colin Watson (cjwatson) on 2018-07-23
tags: added: git lp-code oops trivial
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Critical
status: New → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2018-07-26
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2018-07-26
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers