confusing message: Store upload failed: Authorization failed

Bug #1766911 reported by Ondrej Kubik on 2018-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Colin Watson

Bug Description

LP build is giving confusing error message
"Store upload failed: Authorization failed."
This is for snap that has been previously successfully built and published.
No apparent reason for this error, no changes has been made by developer to previously working build job. Snap is owned by developer.

Related branches

Colin Watson (cjwatson) wrote :

Which build is this, exactly?

affects: launchpad-buildd → launchpad
Changed in launchpad:
status: New → Incomplete
Ondrej Kubik (ondrak) wrote :

it was this snap build:
https://launchpad.net/~ondrak/+snap/toolbox
I believe problem was caused by store having some difficulty, as even trying to re-upload was failing.

Colin Watson (cjwatson) on 2018-05-01
Changed in launchpad:
status: Incomplete → Confirmed
Colin Watson (cjwatson) wrote :

I'm not really sure exactly what the problem is here, but I'm working on a branch that will pick out a more specific error from the store's response, and hopefully that will help.

tags: added: confusing-ui lp-snappy
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Low
status: Confirmed → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2018-05-08
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) wrote :

I've deployed improved error handling now; let us know if you see this again and we should have a better chance of debugging it.

Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers