source uploading with a .buildinfo containing hashes for binary is rejected

Bug #1699763 reported by Mattia Rizzolo on 2017-06-22
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned

Bug Description

This is the original aim of .buildinfo: people upload those file containing the hashes of the built binaries, but without actually uploading the binaries, to check that the binaries rebuilt by another party (i.e. a buildd) matches what expected.
But when uploading a _source.changes (i.e. not actually uploading any binary) with a .buildinfo containing references to the binaries, the upload is rejected with:

Rejected:
Mismatch in binaryfulness. (arch) False != (files) True

Vincent Bernat (vbernat) wrote :

I am also running into this bug by building with --source-only-changes which is useful to locally build the binary to ensure it works, then upload a _source.changes, all in one command.

ProfessorKaos64 (mdeguzis) wrote :

Hit this as well. Preventing me from updating Antimicro for folks over at https://github.com/AntiMicro/antimicro/issues/192. Is there any workaround?

ProfessorKaos64 (mdeguzis) wrote :

Ok I worked around this by just removing the buildinfo from the file list in .changes/source.chanages. Don't bother with any other trickery.

Dawid Dziurla (dawidd0811) wrote :

Yep, would be nice to fix this issue. Just ran into it.

Ross Gammon (rosco2) wrote :

Just ran into this myself. Bit of a pain if you want to test build & install in a ppa.

Changed in launchpad:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.