OOPS when accessing getPublishedBinaries

Bug #1695113 reported by Brian Murray on 2017-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Colin Watson

Bug Description

The phased-updater is encountering an OOPS when trying to use getPublishedBinaries for a resource. Here is the OOPS:

https://oops.canonical.com/?oopsid=OOPS-050cd7cac131a6026f751ac5fdb5f40d

The traceback is about the request expiring.

Related branches

tags: added: oops timeout
Brian Murray (brian-murray) wrote :

Trying to skip over that publication didn't help as I received an OOPS about another one:

https://oops.canonical.com/oops/?oopsid=OOPS-462292a29df91195e2af3b116b1f9b9f

Colin Watson (cjwatson) wrote :

This is awfully reminiscent of bug 1682096, and probably has an almost identical fix. The problem is that we're fetching lots of superfluous columns from the database that we never actually use.

tags: added: lp-soyuz
Changed in launchpad:
status: New → Triaged
importance: Undecided → Critical
Colin Watson (cjwatson) on 2017-06-02
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2017-06-03
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2017-06-05
Changed in launchpad:
status: Fix Committed → Fix Released
tags: added: id-5b9ae29c8a1faf407026739e
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers