PPA generates an endlessly upgrading package

Bug #165230 reported by Tom Hoffman on 2007-11-26
42
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Celso Providelo
Mythbuntu
Fix Released
Low
Unassigned
iPod Convenience
Low
Unassigned

Bug Description

This bug concerns the zope3 package found in our PPA here:

https://edge.launchpad.net/~schooltool-owners/+archive?field.name_filter=zope3&field.status_filter=published

When we create binary .debs from our source package ourselves, everything is fine. When we upload the source package to the PPA, it creates a package which has the odd property of constantly wanting to upgrade itself (to itself). Try it.

Here are the steps I take:

Get the source package from http://ftp.schooltool.org/schooltool/archives/debian unstable main

dch -D feisty -i Auto build for PPA
dpkg-buildpackage -S -sa -rfakeroot
dput schooltool-owners-ppa blahblah.source.changes

Also, quoting our release manager, Brian Sutherland:

Though I'm still totally confused, apparently apt thinks the package on
the server is different from the package that's been installed. It
believes this even though the md5sum and version of the file in the
"Packages" index and the filesystem file match exactly. The only
difference I could detect is that the Packages file is lying about the
maintainer field (seems PPAs do some munging of package metadata).

I believe this to be a bug of either the PPA archive maintenance
software or apt or the Ubuntu PPA builders or a combination of all of
them. Perhaps filing a bug against launchpads PPAs might be the best
idea for further action (feel free to CC me).

You can see the difference between the way apt treats zope3 and
python-zope.ucol:

root@unstable /root # apt-cache policy python-zope.ucol
python-zope.ucol:
 Installed: 1.0.2-r77900-2ubuntu2
 Candidate: 1.0.2-r77900-2ubuntu2
 Version table:
 *** 1.0.2-r77900-2ubuntu2 0
       500 http://ppa.launchpad.net gutsy/main Packages
       100 /var/lib/dpkg/status
root@unstable /root # apt-cache policy zope3
zope3:
 Installed: 3.4.0~b2-1ubuntu2
 Candidate: 3.4.0~b2-1ubuntu2
 Version table:
    3.4.0~b2-1ubuntu2 0
       500 http://ppa.launchpad.net gutsy/main Packages
 *** 3.4.0~b2-1ubuntu2 0
       100 /var/lib/dpkg/status

Celso Providelo (cprov) on 2007-11-27
Changed in launchpad:
assignee: nobody → cprov
status: New → Confirmed
Changed in soyuz:
milestone: none → 1.1.12
status: Confirmed → In Progress
Celso Providelo (cprov) wrote :

Ok, the "endlessly upgrading" behavior is confirmed. It seems to be something similar to what happen in bug #128744 when we have a small inconsistency in the archive indexes. I will investigate the cause of the problem and come back to you anytime tomorrow.

Soren Hansen (soren) wrote :

Just for kicks, I took a peek at this one.

The Packages file in the ppa says:
Maintainer: Brian Sutherland <email address hidden>

In the .deb, it says:
Maintainer: Ubuntu Core Developers <email address hidden>
Original-Maintainer: Brian Sutherland <email address hidden>

I'm pretty sure apt will interpret this as though it's different packages, and hence will keep reinstalling it.

William Grant (wgrant) wrote :

I also note that there are some odd python-version fields at the bottom of some of the records.

William Grant (wgrant) wrote :

Er, sorry, I was looking at the non-PPA version.

On Nov 27, 2007 2:07 AM, Soren Hansen <email address hidden> wrote:
> Just for kicks, I took a peek at this one.
>
> The Packages file in the ppa says:
> Maintainer: Brian Sutherland <email address hidden>
>
> In the .deb, it says:
> Maintainer: Ubuntu Core Developers <email address hidden>
> Original-Maintainer: Brian Sutherland <email address hidden>
>
> I'm pretty sure apt will interpret this as though it's different
> packages, and hence will keep reinstalling it.

But all packages are being mangled, I don't really see why it would
effect this package differently than other PPA packages. If that were
really the problem I would expect a lot more complaints.

-Jordan

Celso Providelo (cprov) wrote :

On Nov 27, 2007 3:23 PM, Jordan Mantha <email address hidden> wrote:
> On Nov 27, 2007 2:07 AM, Soren Hansen <email address hidden> wrote:
> > Just for kicks, I took a peek at this one.
> >
> > The Packages file in the ppa says:
> > Maintainer: Brian Sutherland <email address hidden>
> >
> > In the .deb, it says:
> > Maintainer: Ubuntu Core Developers <email address hidden>
> > Original-Maintainer: Brian Sutherland <email address hidden>
> >
> > I'm pretty sure apt will interpret this as though it's different
> > packages, and hence will keep reinstalling it.
>
> But all packages are being mangled, I don't really see why it would
> effect this package differently than other PPA packages. If that were
> really the problem I would expect a lot more complaints.

Exactly, the Maintainer field is not the culprit in this case.

The problem with zope3 binary package is that it uses 'Pre-depends'
control field and LP omits it in the indexes stanza. Apt assumes the
package changed and tries to re-install it. So, it's really a bug in
LP code.

See further information about missing control fields in bug 172308.

Thanks
--
Celso Providelo <email address hidden>

Mario Limonciello (superm1) wrote :

Both the ipod convenience sync and mythbuntu weekly builds are consequently affected by this since they also use Pre-Depends.

Nic (ntetreau) wrote :

If this is a dupe of a bug marked as fixed, why is it still a bug on my gutsy system? I am having this issue with ipod-convenience package.

Mario Limonciello (superm1) wrote :

Although these both have the same problems, I'm not sure they are
duplicates? As far as I understand, the issue for vmware-server was because
of the section it was in.

The issue for these packages arises because of the use of pre-depends.

Celso can you verify this?

On Dec 12, 2007 10:55 AM, Matt Zimmerman <email address hidden> wrote:

> *** This bug is a duplicate of bug 172275 ***
> https://bugs.launchpad.net/bugs/172275
>
> ** This bug has been marked a duplicate of bug 172275
> vmware-server in feisty-commercial keeps getting reinstalled
>
> --
> PPA generates an endlessly upgrading package
> https://bugs.launchpad.net/bugs/165230
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Mario Limonciello
<email address hidden>

Celso Providelo (cprov) wrote :

Mario,

You are right, this is not a duplication of bug 172275, despite of being related with the same issue (some controls fields are missing from the archive index), the partner-archive could be fixed easily, switching index generation to use apt-ftparchive, we can't do that for PPAs.

A proper fix is coming soon, but meanwhile, avoid the fields mentioned in bug 172308 if you can.

William Grant (wgrant) wrote :

For reference (since bug 172308 is now private, for some reason), here is the list of fields that are omitted from NMAF Sources/Packages files, stolen from cprov's launchpad-users post:

 * Source::Build-Conflicts
 * Source::Build-Conflicts-Indep
 * Binary::Pre-depends
 * Binary::Recommends
 * Binary::Enhances
 * Binary::Breaks
 * Binary::Essential

Changed in soyuz:
milestone: 1.1.12 → 1.2.1
Celso Providelo (cprov) on 2008-01-02
Changed in soyuz:
importance: Undecided → Critical
Andrea Ratto (andrearatto) wrote :

experiencing with the kvm package in my ppa[1]

[1] details: http://andrearatto.homeunix.org/index.php/ubuntu-ppa-repo/

Celso Providelo (cprov) wrote :

RF 5451

Changed in soyuz:
status: In Progress → Fix Committed
Changed in mythbuntu:
status: New → Confirmed
Changed in ipod-convenience:
status: New → Confirmed
Changed in mythbuntu:
importance: Undecided → Low
Changed in ipod-convenience:
importance: Undecided → Low
Celso Providelo (cprov) wrote :

Remember that the fix requires new uploads of the affected sources so we can correctly store and extract the missing DSC fields.

Changed in soyuz:
status: Fix Committed → Fix Released
Mario Limonciello (superm1) wrote :

ipod-convenience sync is fixed with todays upload (on the new launchpad ppa build)

Changed in ipod-convenience:
status: Confirmed → Fix Released
Mario Limonciello (superm1) wrote :

fixed in mythbuntu builds.

Changed in mythbuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers