DistributionSourcePackage:+index incorrectly links versions with epochs

Bug #1629058 reported by Alberto Salvia Novella on 2016-09-29
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Colin Watson

Bug Description

HOW TO REPRODUCE:
1. Go to (https://launchpad.net/ubuntu/+source/unrar-nonfree).
2. Click on a package.

RESULT:
Instead of showing the information from that package, Launchpad redirects to a blank page.

Related branches

Colin Watson (cjwatson) wrote :

This all works for me. Which link in particular did you click on? Were you logged in at the time, or not?

Changed in launchpad:
status: New → Incomplete

Only happens in Chromium and Chrome, but not in Firefox. Not matter if you are logged in or not, if all the extensions are disabled, or even if you run it from the Ubuntu guess session.

The link could be any package under the Ubuntu releases names. Moreover right clicking on those does not show the "open link in new tab" or "open link in new window" options in the drop menu. On the other hand clicking on the names themselves works.

Changed in launchpad:
assignee: nobody → Alberto Salvia Novella (es20490446e)
status: Incomplete → In Progress

Here's a recording of the problem:
(https://youtu.be/gHFj8Alt4II)

Changed in launchpad:
assignee: Alberto Salvia Novella (es20490446e) → nobody
status: In Progress → Confirmed
Colin Watson (cjwatson) wrote :

I see - thanks for the detailed explanation. I believe that this is because the colon in the package's version isn't being URL-encoded in that link, so Chrome/Chromium takes a strict interpretation of it as an unknown scheme or similar while Firefox tolerates it. RFC 1738 is clear that we should be URL-encoding the colon.

Changed in launchpad:
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: trivial ui
Colin Watson (cjwatson) on 2016-09-30
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
William Grant (wgrant) on 2016-10-02
summary: - Can access released packages
+ DistributionSourcePackage:+index incorrectly links versions with epochs
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2016-10-03
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2016-10-03
Changed in launchpad:
status: Fix Committed → Fix Released

Yeah!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers