launchpad git config instructions should include your username

Bug #1600055 reported by Thomi Richards on 2016-07-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Unassigned

Bug Description

On a project's +configure-code page, in the git setup instructions, the instructions mention:

```
Push a new repository

You can add a remote for your Git repository with the command:

git remote add origin git+ssh://git.launchpad.net/pmr

… and push the Git branch to Launchpad with:

git push origin master
```

However this will fail if the user's local shell username is different from their launchpad username. Ideally the instructions should render the users launchpad username, like so:

```
git remote add origin git+ssh://<email address hidden>/pmr
```

Related branches

Kit Randel (blr) on 2016-07-07
Changed in launchpad:
assignee: nobody → Kit Randel (blr)
importance: Undecided → Medium
Kit Randel (blr) on 2016-07-12
Changed in launchpad:
status: New → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) wrote :

r18152 only fixed +configure-code, not the repo listing or repo pages.

tags: added: qa-ok
removed: qa-needstesting
Changed in launchpad:
status: Fix Committed → In Progress

Looks like lp:1590560 could be marked as a duplicate of this one. Not 100% sure though.

HECTOR DAVID (hektve) wrote :

(+1)

Changed in launchpad:
status: In Progress → Fix Released
assignee: Kit Randel (blr) → nobody
assignee: nobody → HECTOR DAVID (hektve)
Colin Watson (cjwatson) on 2017-09-07
Changed in launchpad:
assignee: HECTOR DAVID (hektve) → nobody
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers