can not generate diff with non-UTF-8 encoding files

Bug #1589411 reported by Shawn Wang on 2016-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Colin Watson

Bug Description

Related branches

Shawn Wang (shawn111) on 2016-06-06
description: updated
description: updated
Colin Watson (cjwatson) wrote :

Actually looks like a Launchpad-side problem. I reproduced this locally, and turnip is returning the compare-merge response just fine, but LP crashes when it tries to decode it. It's probably as simple as upgrading LP's simplejson version (since requests uses simplejson if it can).

affects: turnip → launchpad
Changed in launchpad:
importance: Undecided → High
status: New → Triaged
importance: High → Critical
tags: added: git lp-code oops
Colin Watson (cjwatson) on 2016-06-06
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2016-06-06
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2016-06-07
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers