Timeout merging big teams

Bug #156217 reported by Diogo Matsubara on 2007-10-23
6
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Edwin Grubbs

Bug Description

1. Open https://staging.launchpad.net/people/+adminteammerge
2. Fill in "Duplicated team": ubuntu-art
3. Fill in "Target team": motu
4. Click Merge
5. Click Deactivate Members and merge
6. OOPS-661S36

Please complete the following once this bug has been fixed:
  1. https://answers.edge.launchpad.net/launchpad/+question/74120

Guilherme Salgado (salgado) wrote :

As we can see in the OOPS, the timeout happens before we even start the merge. It times out when we try to deactivate all active members of the team (nearly 400) so that we can actually do the merge.

We may look into improving the functions which maintain the TeamParticipate table so that they issue less queries, but since this will only happen if we try to merge teams with /lots/ of members (which is something I don't think people will be doing in practice), I don't think it's something we need to worry about now.

Guilherme Salgado (salgado) wrote :

Empyrical tests (on staging) have shown that we can safely merge teams with as much as 60 active members, although it should be possible to merge teams with more than 100 members, I think.

Guilherme Salgado (salgado) wrote :

Empirical, too.

Changed in launchpad:
importance: Undecided → Low
status: New → Confirmed
Curtis Hovey (sinzui) on 2008-12-31
Changed in launchpad-registry:
status: Confirmed → Triaged
Diogo Matsubara (matsubara) wrote :

On bug 364924 suggested that we should increase the timeout threshold for admins because this bug bit him a few times. Could the importance of this one be increased?

tags: added: chr registry-people
removed: registry
Gavin Panella (allenap) wrote :

This bug is preventing the merging of two teams:
  https://answers.edge.launchpad.net/launchpad/+question/74120

Gavin Panella (allenap) on 2009-06-19
description: updated
Changed in launchpad-registry:
assignee: nobody → Edwin Grubbs (edwin-grubbs)
Changed in launchpad-registry:
status: Triaged → In Progress
Curtis Hovey (sinzui) on 2009-07-10
Changed in launchpad-registry:
importance: Low → High
milestone: none → 2.2.7
status: In Progress → Fix Committed
Edwin Grubbs (edwin-grubbs) wrote :

Landed in rev8828 in devel.

thanks ...

Fixed released in Launchpad sinzui.

Changed in launchpad-registry:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2010-08-04
tags: added: merge-deactivate
removed: registry-people
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions