NascentUpload.do_reject can send an Accepted email

Bug #1530220 reported by William Grant on 2015-12-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
William Grant

Bug Description

NascentUpload.do_reject sends an Accepted email if the upload made it to Done before an exception occurred (eg. because build creation failed). The transaction is still aborted, so the email is a lie, but it is concerning.

The problem is that it attempts to call setRejected, but ignores any exception (usually a QueueInconsistentStateError because Done -> Rejected is invalid). It then calls notify without overriding the status argument.

Related branches

William Grant (wgrant) on 2015-12-30
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) on 2016-01-11
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2016-01-12
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers