login doesn't work from text based browsers

Bug #152706 reported by James Troup on 2007-10-14
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned

Bug Description

login doesn't work from text based browsers (e.g. lynx or w3m). lynx just doesn't work, w3m whines about cookies and RFCs and doesn't work. Apparently this also applies to links2 and elinks, but I haven't tested them myself.

LaserJock (laserjock) wrote :

I tried logging in from https://launchpad.net with elinks and it just kicked me back to launchpad.net. However, when I went to https://launchpad.net/~laserjock/ and logged in it worked. Weird

James Henstridge (jamesh) wrote :

The w3m issue is a duplicate of bug 59510. The problem with Lynx may be the same.

What it boils down to is that the RFC does not accurately reflect what every major web browser implements. We are currently relying on the ability to set a cookie that is sent to both "launchpad.net" and "*.launchpad.net". This works on all the major browsers, but the RFC states that it is illegal.

One way to check if this is the problem is to first try logging in at https://bugs.launchpad.net/ and then try logging in at https://launchpad.net/. If only the first works, then it is a duplicate of 56510.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers