Inconsistent information when trying to change package for a bug

Bug #1484663 reported by teo1978 on 2015-08-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned

Bug Description

What I did:

- I had originally filed a bug to the wrong package, namely Unity,
- I wanted to change it to the correct package which is nvidia-graphics-drivers-340, but I didn't know the exact name of the package a priori
- so I expanded the package selector and I clicked on "choose"
- In the search box, I typed "Nvidia driver"

=> a result appeared, named "nvidia-driver". See first screenshot. It has an icon that resembles a folder

- I clicked on it

Expected behavior:
* EITHER that is supposed to be a kind of "folder", so clicking on it should show its "contents", i.e. a list of packages to choose from,
* OR it is a package name, so clicking on it would selected

Observed behavior:
=> After clicking on it, the package search popup disappeared, and the package field was filled with the name "nvidia-driver".

- So I clicked on Save Changes.

So at this point:
Expected behavior:
Since this was a package name that was found via a search and got proposed to me and I clicked on it and it got to automatically fill the package field, I must assume it is a valid package name. Otherwise I shouldn't even reached this point in the first place (see expected/observed above)

Observed behavior:
- When trying to save changes, I got the error message that "nvidia-driver" is not a valid package.

I bet it isn't, but then again, why on earth did it come out as a search result?!?

All this is completely inconsistent

teo1978 (teo8976) wrote :
teo1978 (teo8976) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers