Junk sounds harsh - reference to tridge's junkcode is too oblique

Bug #147407 reported by Philipp Kern on 2007-09-30
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Unassigned

Bug Description

I want to place many small projects under my personal namespace, so that I publish the repository in my CV. The only way I've found is to place them under +junk, but *junk* is not something to put in my CV.

Being able to start small and garden and improve as things get bigger is a key principle for reducing the learning curve on websites. Forcing a project registration to get started is in tension with that principle, and we will make LP easier to get to know if we do a nicer job of handling no-project-yet or not-worth-a-project code branches.

Previous discussion concluded that we want to change the name to +personal or +personal-branches. This is not as easy as other renames because "+junk" is hard coded into many classes.

Tim Penhey (thumper) wrote :

Yes 'junk' is harsh and it was designed as such.

The purpose was to get users to register projects and use that.

Changed in launchpad:
status: New → Won't Fix
Philipp Kern (pkern) wrote :

So the point is that every upstream project finally gets registered as a Launchpad project, even if this project does not use any Launchpad service? (It's just so confusing for me that there are "Report a bug" buttons even if the project has stated that it does not use Malone, and likewise for other features.)

Tim Penhey (thumper) wrote :

If you are registering branches against the project then it is using a Launchpad service.

There are many products that are registered in Launchpad that don't use the Launchpad bug tracker or translations or other features.

Launchpad is able to track upstream bugs as well, so if there is a bugzilla or other bug tracker, then launchpad can show the status of those external bugs. Launchpad can then be used to link these bugs to other Launchpad projects, or even other external bug trackers.

Philipp Kern (pkern) wrote :

Point taken. I need to a specify a project to link a bug to the upstream bugtracker, this does not seem to be possible without first creating one.

That the branch is only for Debian/Ubuntu packaging is probably negligible. I was confused by the bug view then, which only lists distribution bugs associated with the upstream bugtracker. Fine then.

Renato Silva (renatosilva) wrote :

"The purpose was to get users to register projects and use that."

Sometimes you don't want to create a project, it doesn't mean that your code is junk tough.

That's what I mean with bug 387552.

For example, I have a bunch of small but useful utilities. Should I create a project like My Misc Code? I don't see many sense on this.

Renato Silva (renatosilva) wrote :

* much sense

Morten Kjeldgaard (mok0) wrote :

+junk is not descriptive and sounds unprofessional, hackerish and stupid.

I find +junk very useful for my own branches that I want to be hosted at Launchpad, but I very much resent that Launchpad labels my software as "junk".

What if I wanted a prospective employer to check out some of my software? Would I refer them to my +junk branches? Probably wouldn't impress them very much. Launchpad should have a neutral and professional wording on the site.

I suggest something like "+user" instead, which also signals that the author does not want those to be part of a project.

Tim Penhey (thumper) wrote :

Let's take this to the launchpad-users list. I'm open to suggestions if people feel very strongly.

Changed in launchpad-code:
importance: Undecided → Medium
status: Won't Fix → Triaged
Martin Pool (mbp) wrote :

Did this actually get onto the list?

I think this bug has a fair point: we want to encourage people to create real projects when that makes sense. However:

 * Not all useful branches are real projects.
 * Even branches that are eventually going to become projects may have code before the project is registered, and people want a place to put that. Creating a project object requires some amount of work and commitment and people might not want to go through that up front.

We do have some experience that branches fall in both those categories; we could look at other +junk branches for more.

Using +user would be a small fix. Alternatively we could make a larger change to just put branches directly under the person; that should be done with a view to Launchpad's overall namespace model. And that also connects to the idea of doing team branches.

On Tue, 08 Sep 2009 13:08:10 Martin Pool wrote:
> Did this actually get onto the list?
>
> I think this bug has a fair point: we want to encourage people to create
> real projects when that makes sense. However:
>
> * Not all useful branches are real projects.
> * Even branches that are eventually going to become projects may have code
> before the project is registered, and people want a place to put that.
> Creating a project object requires some amount of work and commitment and
> people might not want to go through that up front.
>
> We do have some experience that branches fall in both those categories;
> we could look at other +junk branches for more.
>
> Using +user would be a small fix.

Although we'd have to keep a +junk redirect for all those remembered
locations.

> Alternatively we could make a larger
> change to just put branches directly under the person; that should be
> done with a view to Launchpad's overall namespace model.

I don't think this is likely. We need to be able to discriminate between a
project and a branch name.

  https://code.launchpad.net/~poolie/bzr

We can't use this as a "junk" branch name as it already goes somewhere else,
so I think we should keep a namespace discriminator like +junk or +user.

> And that also connects to the idea of doing team branches.

There can be team junk branches now (or at least you should be able to).

Tim

I think "personal" branch seems to be the best name for them. I also think a +branch in the url makes more sense than +user or +team do.

I used to be concerned that if we called them anything else, people would be uploading code from a project to their (currently named) +junk area, but there are already users doing this, so I don't think it's that big of a deal.

On Tue, 08 Sep 2009 15:52:00 Paul Hummer wrote:
> I think "personal" branch seems to be the best name for them. I also
> think a +branch in the url makes more sense than +user or +team do.
>
> I used to be concerned that if we called them anything else, people
> would be uploading code from a project to their (currently named) +junk
> area, but there are already users doing this, so I don't think it's that
> big of a deal.

You weren't around when all branch urls had +branch in them (and I think the
code is still there).

We could use +branch instead of +junk or +user.

I didn't get around to asking the launchpad-dev list yet, but we should.

Regardless of whether we change this, we should give users a guided way of turning a junk branch into a real project. If we do change this, it becomes critical that we have such a way.

I filed bug 426067 about this.

Renato Silva (renatosilva) wrote :

I think a neutral name is needed. If the branch belongs to no project, the URL could just try to say that using +orphaned, +noproject etc.

Morten Kjeldgaard (mok0) wrote :

What's happening here? This bug is over 3 years old and the offensive and childish +junk label is still associated with users' private projects.

On Mon, Jan 17, 2011 at 6:44 AM, Morten Kjeldgaard <email address hidden> wrote:
> What's happening here? This bug is over 3 years old and the offensive
> and childish +junk label is still associated with users' private
> projects.
>

We want to have a smooth process for converting a personal branch into
the trunk of a new project before we change the label (see bug
426067
). The paid LP developers aren't planning to fix this right now,
but will be more than happy to help anyone who'd like to fix it
themselves.

Another suggestion is to give users the choice to choose what they
want. For example, what about just accepting anything in the project
component that starts with a '+'. Then I could have branches like:

lp:~jkakar/+junk/some-crap
lp:~jkakar/+config/emacs
lp:~jkakar/+talks/my-slides

And so on. That would be quite nice, I think.

One of the problems with Launchpad, and the conversation here shows it
in some ways, is that we always try to handle massive use cases.
Launchpad should scale down as well as it scales up. For example,
having a nice way to move personal branches to projects sound great,
but I don't think it should be a blocker for making this kind of
lightweight use case nice and simple.

Thats a lovely suggestion. I think we need to think a little bit about
interactions with e.g. +branches which does by-id branch lookup. But
not too much thought.

Martin Pool (mbp) wrote :

That sounds great. Or it could be ~mbp/-foo/whatever, which I think
is not allowed to be a project name, and would avoid collisions with
Launchpad's existing +thing namespaces. Or some other punctuation.
If we make something smooth there we have an easier possibility to do
per-user issues or wikis or whatever (without actually committing to
do it.)

Martin

Changed in launchpad:
importance: Medium → High
tags: added: ui
summary: - Junk sounds too harsh
+ Junk sounds harsh - reference to tridge's junkcode is too oblique
description: updated
Curtis Hovey (sinzui) on 2012-12-03
tags: added: branches teams users
description: updated
Dimitrios Apostolou (jimis) wrote :

Since I'm the one who brought up the CV issue (see bug #1086003), "+junk" is not something you can present to others, let me just add that for the same purpose automatic rendering of README files one level deep under "+personal" would be awesome.

Not fancy features, and I don't care if it's Markdown, reStructuredText (more python friendly?) or pure text, but I want someone who browses my code to first encounter a simple intro before entering the hierarchy tree.

Dimitrios Apostolou (jimis) wrote :

Hi mbp, I couldn't find it, so I reported it here since it's too close to my CV-related bug, which was marked dup of this one.

Anyway, if you mean bug #240067 (per-project wiki), that would be nice but it's different. What I want is parsing and rendering +private/*/README, and that is all. I'm confident that if my request went into that bug, it would never happen, since it's unrelated and much more complicated. It has taken 5 years for a rename, sorry but I don't really expect complex changes to really ever finish.

I can submit a new bug if I connect it somehow to this one, otherwise a new bug will only be a way of forgetting it.

Curtis Hovey (sinzui) wrote :

@Dimitrios
bug #240067 also encompass the desire to parsing of key files and present them in a web page. As Launchpad has only 3 engineers dedicated to fixing critical bugs, only the Launchpad community could provide this feature. Just showing the content of the README would really be a change to loggerhead, which is a code hosting server separate from Launchpad.

As for the removal of +junk, my squad have investigated renaming it twice. unfortunately, the text "+junk" is hard coded in many places, where Lp usually has the names in a configuration file that we can easily change or add aliases for.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints