AttributeError: 'BinaryPatch' object has no attribute 'get_header'

Bug #1471426 reported by Colin Watson on 2015-07-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Kit Randel

Bug Description

Noticed in the OOPS report, e.g. OOPS-50130d5386da2b311efcb88dd623336e:

AttributeError: 'BinaryPatch' object has no attribute 'get_header'

    Traceback (most recent call last):
  Module lazr.jobrunner.jobrunner, line 194, in runJobHandleError
    self.runJob(job, fallback)
  Module lp.services.job.runner, line 289, in runJob
    super(BaseJobRunner, self).runJob(IRunnableJob(job), fallback)
  Module lazr.jobrunner.jobrunner, line 162, in runJob
    job.run()
  Module lp.code.model.branchmergeproposaljob, line 407, in run
    mailer = CodeReviewCommentMailer.forCreation(self.code_review_comment)
  Module lp.code.mail.codereviewcomment, line 87, in forCreation
    code_review_comment.message.rfc822msgid)
  Module lp.code.mail.codereviewcomment, line 77, in __init__
    self._generateBodyBits()
  Module lp.code.mail.codereviewcomment, line 113, in _generateBodyBits
    inline_comment.comments, inline_comment.previewdiff.text)
  Module lp.code.mail.codereviewcomment, line 212, in build_inline_comments_section
    for ph in patch.get_header().splitlines():
AttributeError: 'BinaryPatch' object has no attribute 'get_header'

Looks like a regression from recent work on inline comment mails. Critical per the zero OOPS policy.

Related branches

lp:~blr/launchpad/bug-1471426-commentmail-binarypatch-oops
William Grant: Approve (code) on 2015-07-07
William Grant (wgrant) on 2015-07-07
Changed in launchpad:
assignee: nobody → Bayard 'kit' Randel (blr)
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: Triaged → Fix Committed
Kit Randel (blr) on 2015-07-07
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-07-07
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers