Pushing to a private git repository hangs

Bug #1451107 reported by Luke Faraone on 2015-05-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
William Grant

Bug Description

$ git push lp:~lfaraone/+git/test2 master
Counting objects: 3, done.
Writing objects: 100% (3/3), 209 bytes | 0 bytes/s, done.
Total 3 (delta 0), reused 0 (delta 0)
To git+ssh://<email address hidden>/~lfaraone/+git/test2
 * [new branch] master -> master

$ git push lp:~lfaraone/s3cr8t/+git/test2 master
Counting objects: 3, done.
Writing objects: 100% (3/3), 209 bytes | 0 bytes/s, done.
Total 3 (delta 0), reused 0 (delta 0)

(hangs)

and when I visit the web interface for that repository, I get:
> This repository has no branches.

Future attempts to push to the same repository "works" (although nothing changes):

$ git push lp:~lfaraone/zulip/+git/test2 master
Everything up-to-date

Related branches

William Grant (wgrant) on 2015-05-05
Changed in launchpad:
importance: Undecided → Critical
status: New → Triaged
William Grant (wgrant) on 2015-05-05
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2015-05-06
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-05-11
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers