URLs for latest build of a DistributionSourcePackageRelease on a given architecture

Bug #1403849 reported by Colin Watson on 2014-12-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Colin Watson

Bug Description

http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html needs to be able to construct links to builds for individual architectures for its "missing build on <arch>" and "old binaries left on <arch>" excuses. It would be very helpful if it could do this without having to talk to LP to get the +build URLs, and right now it just links to the DSPR to avoid having to do this. Furthermore, in some cases there may not actually be a build for the architecture in question (perhaps the problem is that the package no longer builds on that architecture but there are still old binaries in -proposed) and in that case we still need to link to the DSPR.

I think the simplest improvement would be to add DSPR:+latestbuild/<archtag>, redirecting to the latest build on the requested architecture if it can find one, otherwise to the DSPR.

Related branches

Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
tags: added: qa-needstesting
Changed in launchpad:
status: New → Fix Committed
Colin Watson (cjwatson) on 2014-12-18
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-01-07
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers