Subject of notification about imported comment includes bug number but no summary

Bug #138775 reported by Matthew Paul Thomas on 2007-09-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

I just received this e-mail notification:
------------
From: Graham Binns <email address hidden>
To: <email address hidden>
...
Date: Mon, 10 Sep 2007 13:16:02 -0000
Message-Id: <email address hidden>
Subject: [Bug 79637]
X-Launchpad-Bug: product=malone; milestone=1.1.9; status=In Progress;
 importance=Medium; <email address hidden>;
...
--
Cve page shouldn't contain bugnomination edit links
https://bugs.launchpad.net/bugs/79637
You received this bug notification because you are a member of Launchpad
Bugs, which is the bug contact for Launchpad Bugs.

--
launchpad-bugs mailing list
...
------------

According to the footer the bug report has a summary, but according to the Subject header it does not.

This could possibly be a problem with the mailing list software, but if it was, I wouldn't expect "[Bug 79637]" to be included in the Subject either.

Diogo Matsubara (matsubara) wrote :

I think this bug happened because of two other bugs:

bug 44197 trailing whitespace should be stripped from single line fields.

bug 70010 resummarized bug report is mailed with old summary.

Fixing one of them would avoid this bug, I believe.

Björn Tillenius (bjornt) wrote :

Has this happened again?

Changed in malone:
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

Yes; I'm attaching two examples. Another manifestation of this problem was apparently fixed as bug 408807, but both these examples are from over two months later.

Matthew Paul Thomas (mpt) wrote :
Matthew Paul Thomas (mpt) wrote :
Changed in malone:
status: Incomplete → New
Matthew Paul Thomas (mpt) wrote :
Matthew Paul Thomas (mpt) wrote :
Curtis Hovey (sinzui) on 2010-01-18
Changed in malone:
status: New → Triaged
importance: Undecided → Low
Graham Binns (gmb) on 2010-06-04
tags: added: story-better-bug-notification
dobey (dobey) wrote :

This seems to be happening again, for notification e-mails due to changes on upstream bugs being watched; as reported in #launchpad IRC.

Laura Czajkowski (czajkowski) wrote :

please see attached image of what I see for a subject in an email

Laura Czajkowski (czajkowski) wrote :

Full email source attached

Robert Collins (lifeless) wrote :

Those bugs are all from duplicates, so we can rule out bug 70010.

Robert Collins (lifeless) wrote :

44197 is unrelated. I suspect a regression in the notification code during all the recent refactorings etc.

summary: - Notification subject included bug number but no summary
+ Notification subject included bug number but no summary for 'subscriber
+ of duplicate' bug notifications
Changed in launchpad:
importance: Low → Critical
tags: added: regression

I'm going to close this bug as Invalid because for bugs managed by Launchpad, it does not occur anymore. The reported instances where it does happen are for when bug comments are imported from an external Bugzilla instance, and for those cases the email subject being [Bug 1234] is by design since we only have the bug id.

Changed in launchpad:
status: Triaged → Invalid
assignee: nobody → Ian Booth (wallyworld)
Changed in launchpad:
status: Invalid → Confirmed
summary: - Notification subject included bug number but no summary for 'subscriber
- of duplicate' bug notifications
+ Notification subject included bug number but no summary
Matthew Paul Thomas (mpt) wrote :

It's not the case that "we only have the bug id". Launchpad knows very well what the bug summary is -- as you can tell by the fact that the e-mail notification contains the summary in the footer! I can't think of any sensible reason to include this information in the footer 100% of the time, and in the Subject only 99.9% of the time.

Examples of this bug that I've received in the past year: bug 867424, bug 399765, bug 1023588, bug 867424, and bug 627195. I wouldn't call it Critical at all, just an annoyance.

(Separately, Apport -- a prolific bug commenter -- sometimes makes comments with empty Subjects, which I confused with this bug. I've now reported that separately as bug 1495436.)

William Grant (wgrant) on 2015-09-14
summary: - Notification subject included bug number but no summary
+ Subject of notification about imported comment includes bug number but
+ no summary
Changed in launchpad:
status: Confirmed → Triaged
assignee: Ian Booth (wallyworld) → nobody
importance: Critical → Low
tags: added: bugs bugwatch
removed: regression
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers