Confusing use of the term "Target to release" on bug pages.

Bug #132733 reported by Jonathan Knowles on 2007-08-15
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Curtis Hovey

Bug Description

Bug pages have a "Target to release" action link.
However, users following this link are taken to a page named "Target bug #x to series".
This is confusing, because "release" and "series" are actually two different concepts.

We should be change the terms used in the link and/or the target page to be consistent with one another.

Jonathan Knowles (jsk) wrote :

A suggestion for the link:

"Target to release series"

Further suggestions for the target page:

For the title: "Target bug #x to a release series".
For the heading: "Release series targets"

Matthew Paul Thomas (mpt) wrote :

If the page is about targeting, why does the checkbox label (and the URL) talk about nominating?

Changed in malone:
importance: Undecided → Medium
status: New → Confirmed
John Frankland (frankland) wrote :

I also find this confusing.
"Target to release" seems to mean "target this bug for fixing in the release series x.x",
but in fact once a release series has been chosen, the bug is presented as "bug found in/affecting release series x.x".
Also, the bug then has two entries under "Affects - Status - Importance - etc.", one with the name of the project (corresponding to trunk ?), the other with the name of the release series, and both can have completely independent values of status, importance, milestone etc. Finally, if a milestone is set for both of these entries, the bug then appears to count twice in the bug statistics!
I think it would be more natural to choose, at the moment of submitting the bug, the release series affected by the bug in question (including trunk).
Then, a completely different question is the targeting of the bugfix to a given release. As the bug can be associated to a milestone, and the milestone is associated with a release series, I think the "series targetting" aspect should be simply handled by linking the bug to a milestone.

Martin Pool (mbp) wrote :

The real meaning of it is "create bugtask for series". Maybe it should say something like that. It's not really a targeting action.

That's confusing, indeed. Even more so for non-native speakers of English.

John A Meinel (jameinel) wrote :

I just wanted to add a bit of a 'me too' on this item. When I saw "Target to Release" it looks like you want to target say 2.0.1, but really it is "target to release series" which is more of a "2.0.*". At least, in Bazaar we have the 2.0.* stable release series, and I wanted to make sure a bug got fixed in that series. Target to Release made it feel like I had to pick an exact release where it would be fixed in. Which was confusing version the "Milestone" target.

Barry Warsaw (barry) wrote :

I wonder why bug report dupe search didn't find this one :(

Anyway, additional thoughts from bug 514132

While we're at it, the +nominate page has a few other minor problems.

* It has no cancel link as is standard
* It provides no way to untarget a series

Ideally this would be a mintlink (a.k.a. ajaxy link) that would pop up a form to select which series the bug should be targeted. For a project with multiple series, this is a great feature, but I fear that it's being somewhat overlooked because of the text and usability issues.

Curtis Hovey (sinzui) on 2010-12-22
Changed in launchpad:
assignee: nobody → Curtis Hovey (sinzui)
status: Triaged → Fix Committed
tags: added: bugjam2010
Curtis Hovey (sinzui) on 2010-12-23
Changed in launchpad:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2011-01-11
Changed in launchpad:
milestone: none → 11.01
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints