Cannot easily import from non-trunk subversion

Bug #130883 reported by David Allouche
8
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Medium
David Allouche

Bug Description

Currently, we cannot import from a Subversion URL that does not contain the word "trunk" without applying a patch to the production code.

This check was put in place after we made a Debian sysadmin angry by checking out (multiple times) the whole repository for debconf, that contains a lot of tags.

<ddaa> So, one way to mitigate the problem, would be to only perform this check on importd-autotest because mwhudson and I are reviewing all imports that we run in production.
<kiko> ddaa, I think that's fine -- consider that a yes from me.
<kiko> drop the check and let you deal with it in the review workflow

Tags: lp-code
David Allouche (ddaa)
Changed in launchpad-bazaar:
status: New → Confirmed
Tim Penhey (thumper)
Changed in launchpad-bazaar:
assignee: nobody → ddaa
importance: Undecided → Medium
David Allouche (ddaa)
Changed in launchpad-bazaar:
status: Confirmed → In Progress
Revision history for this message
David Allouche (ddaa) wrote :

Fix up for review.

Revision history for this message
David Allouche (ddaa) wrote :

RF 4825

Changed in launchpad-bazaar:
status: In Progress → Fix Committed
Revision history for this message
David Allouche (ddaa) wrote :

Released in 1.1.9.

Changed in launchpad-bazaar:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions