unable to revert .po files to a known good state

Bug #1304193 reported by Damien Elmes
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned

Bug Description

Hi there,

A bug in my build scripts accidentally caused a .pot file with ~200 missing strings to be added to my translation repo, causing translations.launchpad.net to delete the entries from all the .po files. I used bzr revert to revert the .po files and .pot to a good state and pushed, but now all the updates are showing in the import queue as "needs review". I am unable to find any way to work around this without manual intervention on your part, so any help would be appreciated.

https://translations.launchpad.net/anki/+imports

Cheers,
Damien

Revision history for this message
William Grant (wgrant) wrote :

You should be able to set those to Approved yourself. Is that not working?

Changed in launchpad:
status: New → Incomplete
Revision history for this message
Damien Elmes (resolve) wrote :

That seems to have worked, thanks. I'm sorry about the noise - when I
previously ran into 'needs review' issues a few years ago it required
manual intervention from Launchpad folks, so I didn't realize that
clicking on approve was an option this time around.

(posting again as my email reply doesn't seem to have come through)

Revision history for this message
William Grant (wgrant) wrote :

Yeah, we only opened that up to project maintainers around 2010 or 2011. Glad it worked out.

Changed in launchpad:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions