Title of artefact too far from the content of the artefact

Bug #127895 reported by Hans Häggström
18
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Matthew Paul Thomas

Bug Description

When looking at artefacts like blueprints or milestones, the title directly above the content is just a fixed text "Blueprint Overview" or "Milestone overview", while the real name of the artefact is up in the left corner of the page, with a smaller black font, and left indented from the actual content.

This makes it disorienting to try to find the name of an artefact that you are looking at.

The fact that we are looking at a 'Blueprint overview' is relatively clear from the context (color of page, plus that we explicitly navigated to a blueprint or were directed to one by a link), so it would make more sense for this text to be smaller and out at the periphery of the vision.

The most important thing about an artefact when starting to read it is its title (it's the shortest summary of the content), so the title should be more visible. In addition, the title of an artefact is conceptually a part of it, so it should be at the same indentation level on the page, directly preceding the text.

A possible fix could be to just switch the places (and possibly sizes) of the title and the type of the page on pages that suffer from this problem (at least blueprints and milestones). However, this might have effects on how other pages are presented also (the placement of the page type text should probably be consistent across pages if possible).

Another way to fix it could be to include the name of the artefact twice, once in the upper left corner, and once in the big colored font above the content, like project overview and bug editing pages do (but in the long run duplication of the information seems a bit redundant).

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Thank you for this report.

Example blueprint page: <https://blueprints.launchpad.net/ubuntu/+spec/dist-upgrader-fixes>
Example milestone page: <https://launchpad.net/ubuntu/+milestone/tribe-6>

Another reason to fix this is the order of things on the page: first header, then tabs, then second header. Because the tabs are after the first header, they should apply to that first header. For example on a blueprint page, the first header should be something that has (most of) an overview, code, bugs, blueprints, translations, and answers. Projects have all these things, but blueprints and milestones do not. Therefore the blueprint/milestone name should come after the tabs, not before.

Changed in launchpad:
assignee: nobody → mpt
importance: Undecided → Medium
status: New → Confirmed
Changed in launchpad:
milestone: none → 1.2.4
Changed in launchpad:
status: Confirmed → In Progress
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Fixed in mainline, r5865, for blueprints. Now to fix it for milestones...

Changed in launchpad:
milestone: 1.2.4 → 1.2.5
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

... Fixed for milestones, r6214.

Changed in launchpad:
status: In Progress → Fix Committed
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers